summaryrefslogtreecommitdiff
path: root/dev-python/binaryornot/binaryornot-0.4.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/binaryornot/binaryornot-0.4.4-r1.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/binaryornot/binaryornot-0.4.4-r1.ebuild')
-rw-r--r--dev-python/binaryornot/binaryornot-0.4.4-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/binaryornot/binaryornot-0.4.4-r1.ebuild b/dev-python/binaryornot/binaryornot-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..b9ce949a9e5d
--- /dev/null
+++ b/dev-python/binaryornot/binaryornot-0.4.4-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Ultra-lightweight pure Python package to guess whether a file is binary or text"
+HOMEPAGE="https://github.com/audreyr/binaryornot"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/chardet-3.0.2[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )"
+
+DOCS=( README.rst HISTORY.rst CONTRIBUTING.rst )
+
+PATCHES=(
+ # https://github.com/audreyr/binaryornot/commit/38dee57986c6679d9936a1da6f6c8182da3734f8
+ "${FILESDIR}"/${P}-tests.patch
+ # Version number has not been updated to 0.4.4
+ "${FILESDIR}"/${P}-fix-version-number.patch
+)
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs