summaryrefslogtreecommitdiff
path: root/dev-python/bert
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-18 04:54:42 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-18 04:54:42 +0000
commit5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (patch)
treec968fff3108e2b4d88e4e564a56bfd066f170573 /dev-python/bert
parent1dde4e5c4b92d849bf1abf0a48135b2a0644f7e1 (diff)
gentoo resync : 18.03.2018
Diffstat (limited to 'dev-python/bert')
-rw-r--r--dev-python/bert/Manifest4
-rw-r--r--dev-python/bert/bert-2.0.0.ebuild23
-rw-r--r--dev-python/bert/files/bert-2.0.0-remove-basestring-fix.patch11
-rw-r--r--dev-python/bert/metadata.xml12
4 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/bert/Manifest b/dev-python/bert/Manifest
new file mode 100644
index 000000000000..e01b125248a5
--- /dev/null
+++ b/dev-python/bert/Manifest
@@ -0,0 +1,4 @@
+AUX bert-2.0.0-remove-basestring-fix.patch 647 BLAKE2B 19b7b65b41be9c3b929c0dc2c92d5f511017f093e924813d547e29a763a0fc23d557798be5542a2991fdb2a808afc087a8e5c40dc03d06d1864564ef6a566aa9 SHA512 e4554308cd81c9b7bd69cac3eed2bb65ce604bfbc494f644b7b0dccbad527af973cb7afb4589b602457ecccbc893f50acbd1031aff87ed30b06f2824ff20d548
+DIST bert-2.0.0.tar.gz 3503 BLAKE2B 6435177493a822166e2f5e2c461f17deb9553aa3aec8893d15e057da9907ae4949246fb19299a1263905e648e0483d2e4cfeddbd2915f2c0d147a0a2bc62daf0 SHA512 643392ab1f8f0cecad9773846a52d5207f3dfeb431c6934b7cdfa523319c1c2aca4b9f8139d0a52ea759df03163b820adb963e4a21284e579a9d139da9acbeb3
+EBUILD bert-2.0.0.ebuild 538 BLAKE2B ea6572b26e5df52012defd70007b17161a86d49042f102d612b0dcf46989a7c2ec6bd2f8550597942046d9182872c0e57ed4844792d5f72ab803b8a49a3cb355 SHA512 8145353748c6db47592070082161042723211aaa74527f5d0191cc8323a2ec5a3d2b017aaa823af218b25d7386efbe5f9d1e982200ac5daf6ad25ad444ad12da
+MISC metadata.xml 389 BLAKE2B 75c3d2580d105790a4507edbc3ea6553d7cbbc96796947441d6ea8e6fdb6344b474cdb86b33a94ba8f7a5537ccc9e7ae1572556d21e56521098aa2c15231f404 SHA512 571fa89a2d05efe16247a98320bc4ce94b0483626d5f9a0e5ea9f72ddc0da3425e56e5b2b6d7cf1a1fc7103aef39cda13edea686947cd91a440014f954ce5314
diff --git a/dev-python/bert/bert-2.0.0.ebuild b/dev-python/bert/bert-2.0.0.ebuild
new file mode 100644
index 000000000000..7e1bb786f7af
--- /dev/null
+++ b/dev-python/bert/bert-2.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="BERT Serialization Library"
+HOMEPAGE="https://pypi.python.org/pypi/bert"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/basho-erlastic[${PYTHON_USEDEP}]"
+
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}/${P}-remove-basestring-fix.patch" )
diff --git a/dev-python/bert/files/bert-2.0.0-remove-basestring-fix.patch b/dev-python/bert/files/bert-2.0.0-remove-basestring-fix.patch
new file mode 100644
index 000000000000..3854e95cdb3a
--- /dev/null
+++ b/dev-python/bert/files/bert-2.0.0-remove-basestring-fix.patch
@@ -0,0 +1,11 @@
+--- a/bert/codec.py 2018-03-07 20:11:38.117925147 -0800
++++ b/bert/codec.py 2018-03-07 20:12:19.681258078 -0800
+@@ -92,7 +92,7 @@
+ return (Atom("bert"), Atom("false"))
+ elif obj is None:
+ return (Atom("bert"), Atom("nil"))
+- elif isinstance(obj, basestring) and not self.__is_ascii(obj):
++ elif isinstance(obj, str) and not self.__is_ascii(obj):
+ return (Atom("bert"), Atom("string"), Atom(self.encoding.upper()), obj.encode(self.encoding))
+ elif isinstance(obj, dict):
+ return (Atom("bert"), Atom("dict"), [(self.convert(k), self.convert(v)) for k, v in obj.items()])
diff --git a/dev-python/bert/metadata.xml b/dev-python/bert/metadata.xml
new file mode 100644
index 000000000000..8d4c44447a12
--- /dev/null
+++ b/dev-python/bert/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">bert</remote-id>
+ <remote-id type="github">samuel/python-bert</remote-id>
+ </upstream>
+</pkgmetadata>