summaryrefslogtreecommitdiff
path: root/dev-python/beautifulsoup4
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-python/beautifulsoup4
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-python/beautifulsoup4')
-rw-r--r--dev-python/beautifulsoup4/Manifest2
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.11.1.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup4/Manifest b/dev-python/beautifulsoup4/Manifest
index b22a155df4e6..da368a14e0b3 100644
--- a/dev-python/beautifulsoup4/Manifest
+++ b/dev-python/beautifulsoup4/Manifest
@@ -1,3 +1,5 @@
DIST beautifulsoup4-4.10.0.tar.gz 399890 BLAKE2B 61f044064a81e94b64a72fd49cca164faa05442bc76f897c8a7fa4481acca039bcb9e4f7a1853a7155504fa25e56c518806d8af016369bc37316ecb95b59d7d3 SHA512 92be99ed0fd479b86519395143516e28f7b80f54a8251223d6e7b88dc98f8dfca9585079f5f1d89bfe68f577de3dff433711642486303203f46bc76754959a18
+DIST beautifulsoup4-4.11.1.tar.gz 517113 BLAKE2B bc0cc8dbb1bffca2d3441a274147f201b79447f2147f7b4c329f05f6d230f9986eebd3709199d0b3c7dba8c15e4ce42e9dc75e290a2bfdfdae643f5dfe07e767 SHA512 7446be07cd55f23def929e6491f0d74a940cf50206ed520b8ae7b9d57bd19ecf6aa821f446ca4f26f1e08b43fcc71fb397886f51a3f0ec691f9e53dfdc7a0cf8
EBUILD beautifulsoup4-4.10.0.ebuild 701 BLAKE2B bc8954ced5f76f0eaba96059a2741dd941efdd2d8ece17ef95e9817e6d6e06fa1194882549c2f4aaff72ac65ede2410c3b5376f3cf4f529fe93f00c0d2d9957a SHA512 34cbcc3d86bac3adf0e0d4c7ad5e19668f076efbd02d0d51cc9d61facdd1e1fd6233874b3cf7957cb13e9125e7fbb006c602ca5b079072ed67d1a521eb56f869
+EBUILD beautifulsoup4-4.11.1.ebuild 740 BLAKE2B faa1b927f4eced50b2a15bdb1d97ddf7049ab545f5d3a98b81b0b29abe0d560241458b3d71d935b0b61bcac8836e4d690665fcf1e405607c2eb5544e2ee8e180 SHA512 bd7436d8001b62db11e7f6a3e6d6ef72294cea365128421f45df54eb10cf482e5eca7157810fd8f141493b918f35ecfef821dcd58bfedfca88016cc834443b50
MISC metadata.xml 745 BLAKE2B 16e44221decda568bcfd7fc64384f3c10d6150801bd099fbee3abb0273fa53bc83494cd9a56d43b125e9b2d773f9e1dcd35820bcc26a28048beea287a9fc3e23 SHA512 b332203a23fbeef550ce75c70afcf6eb9decf4e3e0409899d556e4e12449608100e1e6af81f163a879937bea2726195524559aa1151f917cc9facdf2bde559e0
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.11.1.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.11.1.ebuild
new file mode 100644
index 000000000000..e419a3f8ed3f
--- /dev/null
+++ b/dev-python/beautifulsoup4/beautifulsoup4-4.11.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/soupsieve[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/source