summaryrefslogtreecommitdiff
path: root/dev-python/beautifulsoup4
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-21 06:39:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-21 06:39:12 +0000
commit0464b87d8be9fcf33aebbd906bc0d3a65c953cff (patch)
tree839aded9715eb71cd86edef0ea2a003400b6a63e /dev-python/beautifulsoup4
parentd39430b96ad12b39a0ce35745f3d45d980d1b328 (diff)
gentoo auto-resync : 21:03:2023 - 06:39:12
Diffstat (limited to 'dev-python/beautifulsoup4')
-rw-r--r--dev-python/beautifulsoup4/Manifest2
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.12.0.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup4/Manifest b/dev-python/beautifulsoup4/Manifest
index 12cc1dfeec9f..0f2f04229ae1 100644
--- a/dev-python/beautifulsoup4/Manifest
+++ b/dev-python/beautifulsoup4/Manifest
@@ -1,3 +1,5 @@
DIST beautifulsoup4-4.11.2.tar.gz 517627 BLAKE2B 19fc88dff84c398461ecce3b66b1a92c3541114e3595aa1bae7182914e174d9c36b6de37ba120200695f6dca489c6afcd361244ae9577bc469d20a0864989d48 SHA512 68f5328f881946e80ed1af36b26da184f0af58aaf124f5f623f89c40130e1578f6dbe874b11c802e52c0ec02cfbf6b681e10eb235279631f479d14c2243e7dd3
+DIST beautifulsoup4-4.12.0.tar.gz 523942 BLAKE2B a1cde7726cfe96327300a4c9d44fbf98e3196911be628aa7633633f3515ed6c5d2d0cea61b4a4c9529208bc2339ae070e8e5ffc60d0afec133ca81079b53a49b SHA512 8f4dcaccdcd220f9641c7080d685c1eaa9c851daa579c187fda75a1d85dcf2fe4cc673c2d4b2143682003390ef1d954366ea0d2820e07f8c10418350d31bccd3
EBUILD beautifulsoup4-4.11.2.ebuild 977 BLAKE2B cf084c97939552e1cd2a86e6cbab030b6eded99d6418990124c27d89d8ac6267ae30e5b75b847f0bd952fb0d90dca0a064789f76109b13efa43de92e0236c5db SHA512 d90b28c15af03b7d93d303bd70a135a05e45e7b2b0813185653b640d0f8f6eaa7e1ac3af4e155449674d0f3d3fc7bb06445c0925513e0379e51f0a473dde6149
+EBUILD beautifulsoup4-4.12.0.ebuild 985 BLAKE2B 2b22be5d7ca2725ed56a0eace6d24c061a3ccf463ef43b6a37b848855b2ca4f9134fdb299a142044ba769b4b66d5e605b75469a688c5ddb9ec64969682ba5f29 SHA512 a559d956a38de782512174a4585309540869861d26c8dcaa7b514db0516dc6b2e9c245e33a30dbf72fd86bf529e0fb6414f0544be1325458d31363ce29e59a94
MISC metadata.xml 745 BLAKE2B 16e44221decda568bcfd7fc64384f3c10d6150801bd099fbee3abb0273fa53bc83494cd9a56d43b125e9b2d773f9e1dcd35820bcc26a28048beea287a9fc3e23 SHA512 b332203a23fbeef550ce75c70afcf6eb9decf4e3e0409899d556e4e12449608100e1e6af81f163a879937bea2726195524559aa1151f917cc9facdf2bde559e0
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.12.0.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.12.0.ebuild
new file mode 100644
index 000000000000..3a46f8b73014
--- /dev/null
+++ b/dev-python/beautifulsoup4/beautifulsoup4-4.12.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/soupsieve[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+# bs4 prefers cchardet > chardet > charset-normalizer
+# however, charset-normalizer causes test failures, so force the other two
+# dev-python/chardet[${PYTHON_USEDEP}]
+BDEPEND="
+ test? (
+ || (
+ dev-python/cchardet[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/source