summaryrefslogtreecommitdiff
path: root/dev-python/beartype
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-19 17:09:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-19 17:09:22 +0100
commit590c04803f88a968b4a750c0f420eb314e1fe968 (patch)
treea6d2f2550cb2a6ad9254aa1467aef77488ad32ad /dev-python/beartype
parent66d92fc8569d87a09ac014780528dcad2a12b6c6 (diff)
gentoo auto-resync : 19:09:2023 - 17:09:22
Diffstat (limited to 'dev-python/beartype')
-rw-r--r--dev-python/beartype/Manifest2
-rw-r--r--dev-python/beartype/beartype-0.16.1.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/beartype/Manifest b/dev-python/beartype/Manifest
index 72410286b5a7..e8197b17dead 100644
--- a/dev-python/beartype/Manifest
+++ b/dev-python/beartype/Manifest
@@ -1,3 +1,5 @@
DIST beartype-0.15.0.tar.gz 1002709 BLAKE2B 96aa96135c4e361790856bea3e905afe6cc04b9f4de1e51c9287fcc72917fc7e60e5201cbb147b163499034669e219adf88f727fcb32801eff57a76779186a66 SHA512 3736891230aa8e46145a458d9cca1c62ecb8772b0ed82c56d97fd8e6c86d19dd091d74b1ee0ab5fa5d28218a87d378e514242c53488d56ef8363b054db268de2
+DIST beartype-0.16.1.tar.gz 1039772 BLAKE2B ba3fb71f72c2b332ace7c653d61a8e60546af4f4385dab0676b48759783df33c352edab813c888dc20289044089f7a650c3d56789fc218a044519d0f6982892d SHA512 71ecfaed4113ff1e05a5ba4eef5321da3af7c19bfc53d92906ae2d1c45e5eb8aa4602a3bbd296b242b2a000e03198267ece9c5e963e5216517ad170661e98198
EBUILD beartype-0.15.0.ebuild 760 BLAKE2B a345abe3cef7e841b29dc99985ea96b26b5ec5c1e7c54828ef85860bc524b3fab7c5cc1b0b564cf70e8a2aa0059fc56c6db29d7c48c3c12bfc06569f67b8744d SHA512 cb692762b450a4fdb3e34fdef01cdad2dc40ba22e3f2fbfbec22efee807a0f1e661fa2d4011beb658f8fc594edd73901a5d719258a057c69d4f105ab76ac106c
+EBUILD beartype-0.16.1.ebuild 760 BLAKE2B a345abe3cef7e841b29dc99985ea96b26b5ec5c1e7c54828ef85860bc524b3fab7c5cc1b0b564cf70e8a2aa0059fc56c6db29d7c48c3c12bfc06569f67b8744d SHA512 cb692762b450a4fdb3e34fdef01cdad2dc40ba22e3f2fbfbec22efee807a0f1e661fa2d4011beb658f8fc594edd73901a5d719258a057c69d4f105ab76ac106c
MISC metadata.xml 393 BLAKE2B f22040a947a67160c9b4c2d41db713ea69ae7a272aba75c04b1620e3f813d62718425acbc8c18716981e4176ebeabc5b60e9376d9927552ea5a36b51b7baccdd SHA512 dea8caeb6e9091672994cee213be075819d593d1034cbc7e2b076f3fc32bd2afde13b6af094956885c9ddaa72f272c6a198f4f92e7b095606fdf900a4cec47ec
diff --git a/dev-python/beartype/beartype-0.16.1.ebuild b/dev-python/beartype/beartype-0.16.1.ebuild
new file mode 100644
index 000000000000..1600c2778175
--- /dev/null
+++ b/dev-python/beartype/beartype-0.16.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unbearably fast runtime type checking in pure Python"
+HOMEPAGE="
+ https://pypi.org/project/beartype/
+ https://github.com/beartype/beartype/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fragile performance test
+ beartype_test/a00_unit/a90_decor/test_decorwrapper.py::test_wrapper_fail_obj_large
+ # test for building docs, apparently broken too
+ beartype_test/a90_func/z90_lib/a00_sphinx
+)