summaryrefslogtreecommitdiff
path: root/dev-python/beartype/beartype-0.18.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-22 12:05:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-22 12:05:36 +0100
commit02eb6576978c38afed5787f6f2dbab8353379d66 (patch)
tree0b82220aae58c1307bef3aff0f342f4cdf858161 /dev-python/beartype/beartype-0.18.3.ebuild
parent490ef2c2dc8b4e808f37add1adee21a754efd9a9 (diff)
gentoo auto-resync : 22:04:2024 - 12:05:36
Diffstat (limited to 'dev-python/beartype/beartype-0.18.3.ebuild')
-rw-r--r--dev-python/beartype/beartype-0.18.3.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/beartype/beartype-0.18.3.ebuild b/dev-python/beartype/beartype-0.18.3.ebuild
deleted file mode 100644
index 8337b30a5732..000000000000
--- a/dev-python/beartype/beartype-0.18.3.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Unbearably fast runtime type checking in pure Python"
-HOMEPAGE="
- https://pypi.org/project/beartype/
- https://github.com/beartype/beartype/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv"
-
-BDEPEND="
- test? (
- dev-python/mypy[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # fragile performance test
- beartype_test/a00_unit/a70_decor/test_decorwrapper.py::test_wrapper_fail_obj_large
- # test for building docs, apparently broken too
- beartype_test/a90_func/z90_lib/a00_sphinx
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}