summaryrefslogtreecommitdiff
path: root/dev-python/beartype/beartype-0.17.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-02 17:41:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-02 17:41:59 +0000
commit7c58ecff5764af03b4c65f4115d7b9474e3a5717 (patch)
tree569bdc11cba2d203e04530a1a0dcdc4b52a46de1 /dev-python/beartype/beartype-0.17.1.ebuild
parent708c31c860cb6292743b80e3371ccccffb0c9bbd (diff)
gentoo auto-resync : 02:03:2024 - 17:41:59
Diffstat (limited to 'dev-python/beartype/beartype-0.17.1.ebuild')
-rw-r--r--dev-python/beartype/beartype-0.17.1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/beartype/beartype-0.17.1.ebuild b/dev-python/beartype/beartype-0.17.1.ebuild
deleted file mode 100644
index 8337b30a5732..000000000000
--- a/dev-python/beartype/beartype-0.17.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Unbearably fast runtime type checking in pure Python"
-HOMEPAGE="
- https://pypi.org/project/beartype/
- https://github.com/beartype/beartype/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv"
-
-BDEPEND="
- test? (
- dev-python/mypy[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # fragile performance test
- beartype_test/a00_unit/a70_decor/test_decorwrapper.py::test_wrapper_fail_obj_large
- # test for building docs, apparently broken too
- beartype_test/a90_func/z90_lib/a00_sphinx
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}