summaryrefslogtreecommitdiff
path: root/dev-python/bcrypt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /dev-python/bcrypt
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'dev-python/bcrypt')
-rw-r--r--dev-python/bcrypt/Manifest1
-rw-r--r--dev-python/bcrypt/bcrypt-3.1.4-r1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/bcrypt/Manifest b/dev-python/bcrypt/Manifest
index 27c184b1129a..24e5193f0935 100644
--- a/dev-python/bcrypt/Manifest
+++ b/dev-python/bcrypt/Manifest
@@ -1,5 +1,6 @@
DIST bcrypt-3.1.3.tar.gz 40806 BLAKE2B 60b42bd4326ae1285911a79eff43f871366d6db8f1c2eb102f4f4cd3e91d29e58d30906b542d6f04ec0608dd5583550c0c9ddb795d8fd05cd1802396535ba59b SHA512 1fe80a156cd3707c27d4d3b6495caede3404acfdcd238d0461fdd83249601a0b0f2945e0f531dd4422f19e9cd47107245d8e40eb8b47b78e5c679e7e6b37a92c
DIST bcrypt-3.1.4.tar.gz 42575 BLAKE2B c4521ecfa55e5b857e35c9d9e402b8e911b2546bdb349a4e87f31e6af0a2686ebc9df4fc6268534c65d3bca8facfa2e8ccd549174f8f91a25002e94ba7fb9be4 SHA512 885dadec10aa9c5944a68e73ebc3ba409d41517850fad1bcb61321a8ce4072b95422472b9f7ca76508e9b0d24a86e19f3e415a0713f0a1921b9d3f796089ae71
EBUILD bcrypt-3.1.3.ebuild 1005 BLAKE2B 39535b4fc8ae7ae025cc10f5ea542afa4576475bd8eec08f1b125384b8b566965804ec4140ceee91fdf3ead444a42a735548c65a60fcb9bfb304769647c6e2d5 SHA512 ab702b59dfe325f959c83949c77233172347c8c66f0de917492a8a7adff7574e39eaae9b2a14e31c1b1168e828cdf1699bc018c02575b4ad4592f84df98000d0
+EBUILD bcrypt-3.1.4-r1.ebuild 1021 BLAKE2B d6ae73da4fa348ce633a71c0aab4b8681fe9f1760c708478aa30adcca1d8e53173f0372a9a2f523a3a797af4db7becbea96f6815f79bdc4d26790d85c735feab SHA512 a31b26cd309b02790e3168f025aeceba5627ed3a0a27ce8339688748c4b2d19c22b4b9594cf2f06addb2cd77abcf06c403b75769fbf1090a9a41b930cb78b423
EBUILD bcrypt-3.1.4.ebuild 1022 BLAKE2B e5b3b4d0fc70b586eccf85b9014f33a3156d5b50175e690a4ad745e7bf59e2f74cf1def800561cb59d1f741f6894cbcbbefa5fd2f146788680f939829d1bde66 SHA512 52c377fa09ec1649220ca291761b50c6c4dfcabc1256d0825b843c3aade1d43d957830604afcd8170992278b3a1522d7f7b16a622ca54e83b97a9fcf8f747db7
MISC metadata.xml 485 BLAKE2B 789fde3cb8c29c27778293f22f9e3a4453b743d52f5fab1dd2db6d940e4e1bff843d6ccdb4f7374b456b2cd4f80877f453205bb9a5eeee9f6e32382297ab967b SHA512 3b4fb489f9d1ecdee3dedc58dda61aa86c6bc30f29aba50de6dc4faa499276d83fe15518088e4d0e76c98ca30188b2f1b921807821fc73b5dfc592490e6fdb46
diff --git a/dev-python/bcrypt/bcrypt-3.1.4-r1.ebuild b/dev-python/bcrypt/bcrypt-3.1.4-r1.ebuild
new file mode 100644
index 000000000000..e0abe96cbae9
--- /dev/null
+++ b/dev-python/bcrypt/bcrypt-3.1.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Modern password hashing for software and servers"
+HOMEPAGE="https://github.com/pyca/bcrypt/ https://pypi.org/project/bcrypt/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris"
+IUSE="test"
+
+COMMON_DEPEND="
+ $(python_gen_cond_dep '>=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+"
+DEPEND="${COMMON_DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-3.2.1[${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ !dev-python/py-bcrypt"
+
+python_test() {
+ esetup.py test
+}