summaryrefslogtreecommitdiff
path: root/dev-python/bandit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-10 06:04:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-10 06:04:07 +0000
commit27ecae7b5eb4c80903720ae76a54a68af3447c31 (patch)
tree90b91404883f7c53646987409a6636aa44549bd9 /dev-python/bandit
parent71e206c31e948709a88fafc342bd2d8695942aa5 (diff)
gentoo auto-resync : 10:03:2023 - 06:04:07
Diffstat (limited to 'dev-python/bandit')
-rw-r--r--dev-python/bandit/Manifest2
-rw-r--r--dev-python/bandit/bandit-1.7.5.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/bandit/Manifest b/dev-python/bandit/Manifest
index 2342f6c7a78d..847cd4aa3915 100644
--- a/dev-python/bandit/Manifest
+++ b/dev-python/bandit/Manifest
@@ -1,4 +1,6 @@
AUX bandit-1.7.4-tomli.patch 2465 BLAKE2B ad8f0e6a5880a29d97e3d3f58d58cdf748308605a7dda4817726e8d11f9b8f1d3847cabbf608b6e49c0c85e7e29572625fdfbb681092cab0ebdca6c452c651aa SHA512 2f3a4abdd0b3f25593cea35e10a16971b8df6676e157947a7a8fce8c0f4dcc9f196c7adff3ca62ef8fd3ed7610c2d0be9c850d23c037581d3124d07ffde53f83
DIST bandit-1.7.4.tar.gz 495104 BLAKE2B 5531a602dea877745ebdecf768fa83e0e478c52d472fbfdf98fec32c73a76a73e4f6dd957be760b4757e47c5f9cc25f6cd2f6c593df1e54165e647950a9f8a54 SHA512 93e1a25fd41e9409971f4cbac2ff73971ba270936a6b2aeecb3e0a2aa2015bcefd5eaab3cc94b2d9d96e4604d1a39c5ca1150c9eadd073357a90c5265c592407
+DIST bandit-1.7.5.tar.gz 1970878 BLAKE2B 45787b6d1ebebb5ce25fa67173095a0e97b6f95992d828530cfade8c7f50d0c7b945884539695426f93cf3ed6a42178e18501768aa32c3b0c7019eb20aa3bc95 SHA512 81b93654ba62e6d22e8c2d534b9f575979bad4f66acd90c221d214316cd1863e7c7e179b8e2a2a8fa80034db71ebda8636adb25b36e1827194bb4639e67ada09
EBUILD bandit-1.7.4-r1.ebuild 1131 BLAKE2B 63bdd78d59688da4847f6baedd1ff926290ac81dd6d83d6de74e7059d4bb7550bf1ec611f7f81524a4d7929e662e402f762eed43bd4fa34130971ae2dcccb529 SHA512 22d3ec188e4d7bf2c5dfaf397b8fc35727d18d441b5113b5259d12b191900247ba0221c5bdfeefb0a115d382eb4735b1cd48bd41369a5932f43dba1869638bd3
+EBUILD bandit-1.7.5.ebuild 1050 BLAKE2B 799714dd2660725af9f045ac6377b1621239328200828f16e2a0e80e1930dab2934d7b5bcb3f92302b978467300b80407496b1776fffd9ae66dcad1ba6ced5b4 SHA512 1f033ec6bb38991c44684c1461c3e5f3fcd5b36b852bb43c42bbd89bb5d2ba2cbef41835fd8222152a45a44a6f6a950d75e8f96eda3ce1e4fc16df167408f8f9
MISC metadata.xml 709 BLAKE2B 845208c1e800577f159e34675344ce540c61888393dfcfc2f7c47e77ccfd4784cb3f1990b25b78f97d62c8b5c53feaadfdc894990333a09b7938a90be68b8815 SHA512 ba2c6de072973fcd891e4e161a43d52100df89f13243765cb5b2f2ccd7ef7a5266d8fd6e8d373859b53d6743c1de5b0733d5bb4f81b4a94d95843e0593e9dc8f
diff --git a/dev-python/bandit/bandit-1.7.5.ebuild b/dev-python/bandit/bandit-1.7.5.ebuild
new file mode 100644
index 000000000000..bcb0d9b011a0
--- /dev/null
+++ b/dev-python/bandit/bandit-1.7.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="
+ https://github.com/PyCQA/bandit/
+ https://pypi.org/project/bandit/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/GitPython-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup4-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.9.4[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+ )
+"
+
+distutils_enable_tests unittest