summaryrefslogtreecommitdiff
path: root/dev-python/bandit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /dev-python/bandit
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'dev-python/bandit')
-rw-r--r--dev-python/bandit/Manifest4
-rw-r--r--dev-python/bandit/bandit-1.6.2.ebuild47
-rw-r--r--dev-python/bandit/metadata.xml2
3 files changed, 51 insertions, 2 deletions
diff --git a/dev-python/bandit/Manifest b/dev-python/bandit/Manifest
index bbb12746f658..a16927bcbba4 100644
--- a/dev-python/bandit/Manifest
+++ b/dev-python/bandit/Manifest
@@ -1,3 +1,5 @@
DIST bandit-1.5.1.tar.gz 480856 BLAKE2B f8a1a7dc1d93a1b6c8d3eb5bcbecda895b29dfebe055ac358b9437bd0c9ab5562e6d25a658bc2092cff6bddfd0245e71bf39ee88b2718e3a0c7376fa50293ae1 SHA512 e6f596e73af45ca2ff4d200fad63d37adf44efd5de52f8061f5a349b66457a39eb442ad442d5fb57b2e0e98c8bae0eb0879b958ff619b4e26c0183bc8b928e36
+DIST bandit-1.6.2.tar.gz 498567 BLAKE2B ab7885df634ff8258fc7620523b56995cb2f262f4290193a9063e216f66ba8ecb31ec17f09d0b72a0472923266953c46e47e74fcdfb39784873738c033e00c6c SHA512 9facce98411ceb9e33e5a978ca4aad2dab541ffe215e480806ac921b7f7067572445d8e32e8d473ef30bb57155b72b2ffd4e06d458a3da82e2a9fb1b1d8a4b9f
EBUILD bandit-1.5.1-r1.ebuild 1307 BLAKE2B f2b7b0b9a0de146487bd4358d52d627af24cc58edcdb196dd4c9f40b185b999dce54241fae007d41a08415323ff3244ba38f0e54d184998c94466d2467c69808 SHA512 7e7c563cdf27c80b370c2bbfdadb96a25b3bfb3c2928ddc5318e9870edb0f3c987f72cd6ef6b4520ea67e8000d1e87c1ae4c36fddaebc176f33bc8299de35db6
-MISC metadata.xml 437 BLAKE2B e9d2b3bbc3f4795ca95af1113008d33a635efed8ab7b6da63fc1b73f426b37b7fda1dfba1f0737e8dc116447b873515d37c628d00876f480fc654a78eef9c2ef SHA512 3e34e842afdbdf7c90b6a9ed8f11d4b4955c03f7f3b3a9cde02b2fa33bcba39a00556e62c5c29b721e3d25d33de8396b5dd9737037f9000b1fc3e707ab9fd9bd
+EBUILD bandit-1.6.2.ebuild 1319 BLAKE2B 4f56cab706377bed33276d7dc1248091293d412c5c027a6ae46c6d83be3562d68a2aefa5cef4263d77525ed3a975ae88b16a4ce4b870bc26b693e54a6f4a2b07 SHA512 0edba14561d46779f4f252fcad29e2078a7e0978210585cecfa6f15c835c9e037a2381948eece197bcb306df41c9faa53a9a76b9239e3004f638061a6306dba4
+MISC metadata.xml 632 BLAKE2B d36f7c8fa4f8bb896f1eb1ddcdafa2705aeec74ae61c75f2bcebee5b8060442721448afa709099cf2f5d0c6f4dcd9d622c44f94258eb846be36f7d9b82c0ccd6 SHA512 cd90a77633abd61030fe7412b929c129b2e8bb8fe3b265277e8fdbe7b6a9ada8503c5bc97dc6754ba6f4137cfc96bd508b1750bc7b9baa58d823892febb5e955
diff --git a/dev-python/bandit/bandit-1.6.2.ebuild b/dev-python/bandit/bandit-1.6.2.ebuild
new file mode 100644
index 000000000000..3f077f18a76b
--- /dev/null
+++ b/dev-python/bandit/bandit-1.6.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="https://github.com/PyCQA/bandit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~s390 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hacking-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stestr-1.0.0
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup-4.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.4.5[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/git-python-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.13.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ stestr init
+ stestr run || die
+}
diff --git a/dev-python/bandit/metadata.xml b/dev-python/bandit/metadata.xml
index 8ee1f52b6c10..40f27867ff32 100644
--- a/dev-python/bandit/metadata.xml
+++ b/dev-python/bandit/metadata.xml
@@ -6,7 +6,7 @@
<name>Matthew Thode</name>
</maintainer>
<longdescription lang="en">
- A tool designed to find common security issues in Python code.
+ Bandit is a tool designed to find common security issues in Python code. To do this Bandit processes each file, builds an AST from it, and runs appropriate plugins against the AST nodes. Once Bandit has finished scanning all the files it generates a report.
</longdescription>
<upstream>
<remote-id type="pypi">bandit</remote-id>