summaryrefslogtreecommitdiff
path: root/dev-python/awxkit/awxkit-21.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
commitafa8da78d8135ca28150730e9c60af9d875f0a5b (patch)
tree65e94479f29d7591a1bc1d09d1fc1913d785fe6b /dev-python/awxkit/awxkit-21.6.0.ebuild
parent4828c25c25aacf399de429d381288982fd7e0d0e (diff)
gentoo auto-resync : 14:11:2022 - 06:50:13
Diffstat (limited to 'dev-python/awxkit/awxkit-21.6.0.ebuild')
-rw-r--r--dev-python/awxkit/awxkit-21.6.0.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/awxkit/awxkit-21.6.0.ebuild b/dev-python/awxkit/awxkit-21.6.0.ebuild
deleted file mode 100644
index 539f927196c4..000000000000
--- a/dev-python/awxkit/awxkit-21.6.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Command line interface for Ansible AWX"
-HOMEPAGE="
- https://github.com/ansible/awx/
- https://pypi.org/project/awxkit/
-"
-SRC_URI="https://github.com/ansible/awx/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}/awx-${PV}/awxkit"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
- dev-python/pyjwt[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
- sed -e 's|websocket-client==[[:digit:]\.]*|websocket-client|' \
- -e "/'clean'/d" \
- -i setup.py || die
- distutils-r1_src_prepare
-}