summaryrefslogtreecommitdiff
path: root/dev-python/awscli/awscli-1.14.50.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /dev-python/awscli/awscli-1.14.50.ebuild
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'dev-python/awscli/awscli-1.14.50.ebuild')
-rw-r--r--dev-python/awscli/awscli-1.14.50.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/awscli/awscli-1.14.50.ebuild b/dev-python/awscli/awscli-1.14.50.ebuild
new file mode 100644
index 000000000000..09f1db16250d
--- /dev/null
+++ b/dev-python/awscli/awscli-1.14.50.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.python.org/pypi/awscli"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/botocore-1.8.20[${PYTHON_USEDEP}]
+ <=dev-python/colorama-0.3.3[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ <=dev-python/rsa-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.1.12[${PYTHON_USEDEP}]
+ <=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "