summaryrefslogtreecommitdiff
path: root/dev-python/aws-xray-sdk-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 07:53:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 07:53:35 +0000
commite393c0503a79342594a61547dc43f80f8bcc086e (patch)
tree3254e8166c98b932add34913169c98f7b7f9fa5f /dev-python/aws-xray-sdk-python
parentb46782805d0eed36ce9685f7e9abf25671f24d7d (diff)
gentoo auto-resync : 21:12:2022 - 07:53:34
Diffstat (limited to 'dev-python/aws-xray-sdk-python')
-rw-r--r--dev-python/aws-xray-sdk-python/Manifest1
-rw-r--r--dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.11.0-r1.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/aws-xray-sdk-python/Manifest b/dev-python/aws-xray-sdk-python/Manifest
index e987e87a7dfc..1e423d01e479 100644
--- a/dev-python/aws-xray-sdk-python/Manifest
+++ b/dev-python/aws-xray-sdk-python/Manifest
@@ -1,4 +1,5 @@
AUX aws-xray-sdk-python-2.8.0-fix-py3.10-loops.patch 1533 BLAKE2B 709ffaa46c2934fda754745f918bd54444433d5d57c6bca65d8c9be5b940e7ec91f8de47e94a31262ecf7126bb2068ed453ad18a4d6a07fae42d2bf6e764a600 SHA512 fcea4f8e094d1c3354897349c8705e7268e264d9699ec61609796d451db865931b1c2fd4e273fb80427645c0968993756e685e688d303e7fbe7c0bdce88d968f
DIST aws-xray-sdk-python-2.11.0.gh.tar.gz 275430 BLAKE2B 1c1d3b56629dbd822b4f9fcb1e7ba5b43fbbff55fbe7ac02d75e0bb50629c4a0e5baed2b4c14c4c8a7775d60da5b285f96bca68b68b64ddf03aeec0c6094c74c SHA512 62035db955ce3d60e6d75088b7255dec83b21b4fd02353146b34bc48bdacff805b711b5caaca7adbbb5c5a3632a97910907d04681f36c198c99fbb4ef1cc4f85
+EBUILD aws-xray-sdk-python-2.11.0-r1.ebuild 2214 BLAKE2B 8a49a6de5e687607a27d318c623d59663e54592ad2d8b86e61299d51bbeae5a073689d491e1ecf032568d6b9918cb81f8a1eff7cea7296a7448a63d8c9078c9f SHA512 7bcd41d13cbc47de69014c6c0762a556b4018fc96a6a086ed3019b2bc24efa6b58f250d3c9189ca5449b47eea2f21317943dc61b812a23d8b4606561f1665a46
EBUILD aws-xray-sdk-python-2.11.0.ebuild 2211 BLAKE2B 98a84bf16a6fedf6c7612fee214a4ed861533d8b489737c5081fbfc1a70c0fc8e73a65134aad1e22411dd0846884174587b091161077d509db2480fce5c79e0f SHA512 89ae140dbe28f22d9db238c47d8f5565c4252f74f6b7aaf9eaf1b002b612480389a51b11db29da64b87a7f3851a4b76650e2b6d9bf92fd57845f011ed3ec8004
MISC metadata.xml 579 BLAKE2B 3f7aaed38bcceb97fb3597954ca9075ddf7a5718bcac69327be2b99d241c6d8cb0eefd369ca892c8d751703de9067c7eadf19f8c4445334ee8e4952b99fef69e SHA512 f3033cf16f60cae6727f80bd53944972f851579ffef8101cf6fda45e2575696183ec92ea8c994a77bbf3ffc8219be2ae2fae456faabe73a9896bcefddf3b5db5
diff --git a/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.11.0-r1.ebuild b/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.11.0-r1.ebuild
new file mode 100644
index 000000000000..585ad0e63fc6
--- /dev/null
+++ b/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.11.0-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="AWS X-Ray SDK for Python"
+HOMEPAGE="
+ https://github.com/aws/aws-xray-sdk-python/
+ https://pypi.org/project/aws-xray-sdk/
+"
+SRC_URI="
+ https://github.com/aws/aws-xray-sdk-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-1.12.122[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ <dev-python/flask-sqlalchemy-3[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.4[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.8.0-fix-py3.10-loops.patch"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=tests.ext.django.app.settings
+ local -x AWS_SECRET_ACCESS_KEY=fake_key
+ local -x AWS_ACCESS_KEY_ID=fake_id
+
+ local EPYTEST_DESELECT=(
+ # Internet access
+ tests/test_patcher.py::test_external_file
+ tests/test_patcher.py::test_external_module
+ tests/test_patcher.py::test_external_submodules_full
+ tests/test_patcher.py::test_external_submodules_ignores_file
+ tests/test_patcher.py::test_external_submodules_ignores_module
+ # benchmark
+ tests/test_local_sampling_benchmark.py
+ # Fails, probably because above is ignored
+ tests/test_async_local_storage.py::test_localstorage_isolation
+ tests/test_async_recorder.py::test_capture
+ tests/test_async_recorder.py::test_concurrent_calls
+ tests/test_async_recorder.py::test_async_context_managers
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged deps
+ tests/ext/aiobotocore
+ tests/ext/pg8000
+ tests/ext/psycopg2
+ tests/ext/pymysql
+ tests/ext/pynamodb
+ tests/ext/sqlalchemy_core/test_postgres.py
+ tests/ext/django/test_db.py
+ # Internet access
+ tests/ext/httplib
+ tests/ext/httpx
+ tests/ext/requests
+ # requires old package vesions
+ tests/ext/django
+ tests/ext/aiohttp
+ )
+
+ epytest -p no:django
+}