summaryrefslogtreecommitdiff
path: root/dev-python/aws-xray-sdk-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-python/aws-xray-sdk-python
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-python/aws-xray-sdk-python')
-rw-r--r--dev-python/aws-xray-sdk-python/Manifest3
-rw-r--r--dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.8.0.ebuild40
-rw-r--r--dev-python/aws-xray-sdk-python/files/aws-xray-sdk-python-2.8.0-fix-py3.10-loops.patch36
3 files changed, 57 insertions, 22 deletions
diff --git a/dev-python/aws-xray-sdk-python/Manifest b/dev-python/aws-xray-sdk-python/Manifest
index 6b97c0e7b4b0..db8d24a0a748 100644
--- a/dev-python/aws-xray-sdk-python/Manifest
+++ b/dev-python/aws-xray-sdk-python/Manifest
@@ -1,3 +1,4 @@
+AUX aws-xray-sdk-python-2.8.0-fix-py3.10-loops.patch 1533 BLAKE2B 709ffaa46c2934fda754745f918bd54444433d5d57c6bca65d8c9be5b940e7ec91f8de47e94a31262ecf7126bb2068ed453ad18a4d6a07fae42d2bf6e764a600 SHA512 fcea4f8e094d1c3354897349c8705e7268e264d9699ec61609796d451db865931b1c2fd4e273fb80427645c0968993756e685e688d303e7fbe7c0bdce88d968f
DIST aws-xray-sdk-python-2.8.0.gh.tar.gz 267880 BLAKE2B 7a433a0b1b3ca38a100f3b23c79e9b0d7f84cb096f6d30832fdf16f171f9528aee8b81aaf3ba263a90d46f791de8b2f37a919651f9699e5fcf3073db83fc25b4 SHA512 e0fb3fb0bfbd963863714537ea12771df7ffa2857aaf4cdb6414d71ecdfc65c2623fa40a6a48c4eab30f4370d545a595db2762932133a6eba56121a4048502fb
-EBUILD aws-xray-sdk-python-2.8.0.ebuild 1959 BLAKE2B 4cbfd1a75bfff81594827f5e30a620e2e77e79ff04e477c23dc9b12712b6a21d97fca09737a21125d4f276c5f735a7ea6b81ab03d9f479d393534ad2e59ce8a8 SHA512 801b8ce365aa8f8a8cd8027e58ad06d3e6bdaafdd1b552eded48769e6ad02ed41178e2cdb790a2aacdce9522dfd7cf1c438be5ee575dc88a307391bb972e4c27
+EBUILD aws-xray-sdk-python-2.8.0.ebuild 1889 BLAKE2B 24cda4c7475ce303afb3b03771940db8053f72a3b18b6f0925901df1605cd19fc23a7fc4f85cb0a5444c8e3460b54a939cadea95b6347a07ba941a0629247ce3 SHA512 22ec28c20ea51e9816a41a2c13230d9cfdabcf2d0d654732a39f5a416a716a0e387c262c0a3dc7434dde4c296675aaeb14737259401aba1a10334f3f00d3c35c
MISC metadata.xml 478 BLAKE2B 963cbec10db90be7fe2d7beef8920049b56d349eea7cc5fe97f2d4f99499a270651639ed2fed053742bb158387039bf225138708ba42e0670e3e101844127415 SHA512 2d7c682a648cffc2d65d6a5f340cec835cd67bc1dc28395ca8ec87bcedc78b290f6101f0455b89260b9b7ab1eb208c56a1bd74d3feaba09845a834e1e2bc5bcb
diff --git a/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.8.0.ebuild b/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.8.0.ebuild
index 560c3e416dac..d07a31c0dce9 100644
--- a/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.8.0.ebuild
+++ b/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.8.0.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -15,7 +16,6 @@ SRC_URI="
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
RDEPEND="
>=dev-python/botocore-1.12.122[${PYTHON_USEDEP}]
@@ -33,6 +33,10 @@ BDEPEND="
dev-python/webtest[${PYTHON_USEDEP}]
)"
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.10-loops.patch"
+)
+
distutils_enable_tests pytest
python_test() {
@@ -40,34 +44,28 @@ python_test() {
local -x AWS_SECRET_ACCESS_KEY=fake_key
local -x AWS_ACCESS_KEY_ID=fake_id
- local args=(
- # unpackaged deps
- --ignore tests/ext/aiobotocore
- --ignore tests/ext/pg8000
- --ignore tests/ext/psycopg2
- --ignore tests/ext/pymysql
- --ignore tests/ext/pynamodb
- --ignore tests/ext/sqlalchemy_core/test_postgres.py
- --deselect tests/ext/django/test_db.py
-
+ local EPYTEST_DESELECT=(
# Internet access
- --deselect
tests/test_patcher.py::test_external_file
- --deselect
tests/test_patcher.py::test_external_module
- --deselect
tests/test_patcher.py::test_external_submodules_full
- --deselect
tests/test_patcher.py::test_external_submodules_ignores_file
- --deselect
tests/test_patcher.py::test_external_submodules_ignores_module
- --deselect
tests/ext/aiohttp/test_client.py
- --ignore
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged deps
+ tests/ext/aiobotocore
+ tests/ext/pg8000
+ tests/ext/psycopg2
+ tests/ext/pymysql
+ tests/ext/pynamodb
+ tests/ext/sqlalchemy_core/test_postgres.py
+ tests/ext/django/test_db.py
+ # Internet access
tests/ext/httplib
- --ignore
tests/ext/requests
)
- epytest -p no:django "${args[@]}"
+ epytest -p no:django
}
diff --git a/dev-python/aws-xray-sdk-python/files/aws-xray-sdk-python-2.8.0-fix-py3.10-loops.patch b/dev-python/aws-xray-sdk-python/files/aws-xray-sdk-python-2.8.0-fix-py3.10-loops.patch
new file mode 100644
index 000000000000..cde91a8d0cda
--- /dev/null
+++ b/dev-python/aws-xray-sdk-python/files/aws-xray-sdk-python-2.8.0-fix-py3.10-loops.patch
@@ -0,0 +1,36 @@
+diff --git a/tests/ext/aiohttp/test_middleware.py b/tests/ext/aiohttp/test_middleware.py
+index c8b2333..4f8cac6 100644
+--- a/tests/ext/aiohttp/test_middleware.py
++++ b/tests/ext/aiohttp/test_middleware.py
+@@ -279,8 +279,7 @@ async def test_concurrent(test_client, loop, recorder):
+
+ await asyncio.wait([get_delay(), get_delay(), get_delay(),
+ get_delay(), get_delay(), get_delay(),
+- get_delay(), get_delay(), get_delay()],
+- loop=loop)
++ get_delay(), get_delay(), get_delay()])
+
+ # Ensure all ID's are different
+ ids = [item.id for item in recorder.emitter.local]
+diff --git a/tests/test_async_local_storage.py b/tests/test_async_local_storage.py
+index b43cc0e..4b13ffd 100644
+--- a/tests/test_async_local_storage.py
++++ b/tests/test_async_local_storage.py
+@@ -19,7 +19,7 @@ def test_localstorage_isolation(loop):
+ random_int = random.random()
+ local_storage.randint = random_int
+
+- await asyncio.sleep(0.0, loop=loop)
++ await asyncio.sleep(0.0)
+
+ current_random_int = local_storage.randint
+ assert random_int == current_random_int
+@@ -30,7 +30,7 @@ def test_localstorage_isolation(loop):
+
+ # Run loads of concurrent tasks
+ results = loop.run_until_complete(
+- asyncio.wait([_test() for _ in range(0, 100)], loop=loop)
++ asyncio.wait([_test() for _ in range(0, 100)])
+ )
+ results = [item.result() for item in results[0]]
+