summaryrefslogtreecommitdiff
path: root/dev-python/aws-xray-sdk-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-03 23:21:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-03 23:21:12 +0100
commit979898cb45139dd0e6727a01df15b602f74a8dd3 (patch)
tree6c18ca0165dc1a0477e0c9c9253c98f03f26da67 /dev-python/aws-xray-sdk-python
parent09f46eb2a6639c039b0b4268a8410d93bbf14e9e (diff)
gentoo auto-resync : 03:04:2023 - 23:21:12
Diffstat (limited to 'dev-python/aws-xray-sdk-python')
-rw-r--r--dev-python/aws-xray-sdk-python/Manifest2
-rw-r--r--dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.12.0.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/aws-xray-sdk-python/Manifest b/dev-python/aws-xray-sdk-python/Manifest
index 03f918b4673b..341f3a500db1 100644
--- a/dev-python/aws-xray-sdk-python/Manifest
+++ b/dev-python/aws-xray-sdk-python/Manifest
@@ -1,4 +1,6 @@
AUX aws-xray-sdk-python-2.8.0-fix-py3.10-loops.patch 1533 BLAKE2B 709ffaa46c2934fda754745f918bd54444433d5d57c6bca65d8c9be5b940e7ec91f8de47e94a31262ecf7126bb2068ed453ad18a4d6a07fae42d2bf6e764a600 SHA512 fcea4f8e094d1c3354897349c8705e7268e264d9699ec61609796d451db865931b1c2fd4e273fb80427645c0968993756e685e688d303e7fbe7c0bdce88d968f
DIST aws-xray-sdk-python-2.11.0.gh.tar.gz 275430 BLAKE2B 1c1d3b56629dbd822b4f9fcb1e7ba5b43fbbff55fbe7ac02d75e0bb50629c4a0e5baed2b4c14c4c8a7775d60da5b285f96bca68b68b64ddf03aeec0c6094c74c SHA512 62035db955ce3d60e6d75088b7255dec83b21b4fd02353146b34bc48bdacff805b711b5caaca7adbbb5c5a3632a97910907d04681f36c198c99fbb4ef1cc4f85
+DIST aws-xray-sdk-python-2.12.0.gh.tar.gz 275773 BLAKE2B a78ac201524e70a342100c2e76e93bb02ed76e183dfca2e8737230061182d94c9a7f4eba183bc731d2ed79a8e4dda486ea09cb304f4cd58da56d712b8e6c5749 SHA512 0616369f95bf0de710ab5fb868d1a84280bcc1180cc205e6a6e0c405eae131fb861de75fea00c9c1be4e163b9d292cc27e08f624c7b6981ba4a3b8d99dbbb63c
EBUILD aws-xray-sdk-python-2.11.0-r1.ebuild 2212 BLAKE2B be3bc84442d350b7b97b9c741699f7619797aecf9045b24d86ce659e02a8bbd502a83bd597439ffceafb55ba28b66976de0854f3b0fa5280ae06c018aa4af939 SHA512 ac2931312c166321d74d15fae157b0489355fd4cb11feab425b9b0bae24a5ef1bf515e9e920e75cd3167a88cc2d2bb7196810deb973c6d89a27ca4049e3a730c
+EBUILD aws-xray-sdk-python-2.12.0.ebuild 2196 BLAKE2B a01d366c35bcdde673f44d800f28028906d15d51ded9e6dbc7d3713bb1fa5a36a8252a86a584035319ee614e6767d647c2e4810f1f46167e7a413cf745971af7 SHA512 09b5102c41acc053167396a6a91390a4ad1a447e46f5912b00634e161f2943e463d43ca77e76e2bcb21ecb0bffcc29c52240a9121feb64c239c6c369039331d6
MISC metadata.xml 579 BLAKE2B 3f7aaed38bcceb97fb3597954ca9075ddf7a5718bcac69327be2b99d241c6d8cb0eefd369ca892c8d751703de9067c7eadf19f8c4445334ee8e4952b99fef69e SHA512 f3033cf16f60cae6727f80bd53944972f851579ffef8101cf6fda45e2575696183ec92ea8c994a77bbf3ffc8219be2ae2fae456faabe73a9896bcefddf3b5db5
diff --git a/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.12.0.ebuild b/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.12.0.ebuild
new file mode 100644
index 000000000000..610caf67ed1f
--- /dev/null
+++ b/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.12.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="AWS X-Ray SDK for Python"
+HOMEPAGE="
+ https://github.com/aws/aws-xray-sdk-python/
+ https://pypi.org/project/aws-xray-sdk/
+"
+SRC_URI="
+ https://github.com/aws/aws-xray-sdk-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-1.12.122[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ <dev-python/flask-sqlalchemy-3[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.4[${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-2[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=tests.ext.django.app.settings
+ local -x AWS_SECRET_ACCESS_KEY=fake_key
+ local -x AWS_ACCESS_KEY_ID=fake_id
+
+ local EPYTEST_DESELECT=(
+ # Internet access
+ tests/test_patcher.py::test_external_file
+ tests/test_patcher.py::test_external_module
+ tests/test_patcher.py::test_external_submodules_full
+ tests/test_patcher.py::test_external_submodules_ignores_file
+ tests/test_patcher.py::test_external_submodules_ignores_module
+ # benchmark
+ tests/test_local_sampling_benchmark.py
+ # Fails, probably because above is ignored
+ tests/test_async_local_storage.py::test_localstorage_isolation
+ tests/test_async_recorder.py::test_capture
+ tests/test_async_recorder.py::test_concurrent_calls
+ tests/test_async_recorder.py::test_async_context_managers
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged deps
+ tests/ext/aiobotocore
+ tests/ext/pg8000
+ tests/ext/psycopg2
+ tests/ext/pymysql
+ tests/ext/pynamodb
+ tests/ext/sqlalchemy_core/test_postgres.py
+ tests/ext/django/test_db.py
+ # Internet access
+ tests/ext/httplib
+ tests/ext/httpx
+ tests/ext/requests
+ # requires old package vesions
+ tests/ext/django
+ tests/ext/aiohttp
+ )
+
+ epytest -p no:django
+}