summaryrefslogtreecommitdiff
path: root/dev-python/autopep8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
commit6b933047f46efec1aa747570f945344254227457 (patch)
treea12a4b87b38f954c4de435272cf4b90d721df5e8 /dev-python/autopep8
parentf45955e60d4da9b7f4a1088c98042f9c06669039 (diff)
gentoo resync : 15.12.2017
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest2
-rw-r--r--dev-python/autopep8/autopep8-1.3.3.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index b8eae1f29c81..7eeb60348e58 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,4 +1,6 @@
DIST autopep8-1.3.2.tar.gz 107915 BLAKE2B 3148f12616babc26415fc138d5d9e2d2a83cc735449cea54870662dabdfebfd298d96ca716ee62c9143049a2abf05e6a597b0ec6bab90c557dae63999794ea25 SHA512 cb9a5e297ce705722d5e65472dbe749e57fa12fe8dee0d4c3dc20d9e885e0d885339627667110318c89c6bf7e337203a7831c0e2217e5a5d7951edcb98d3df4f
+DIST autopep8-1.3.3.tar.gz 108639 BLAKE2B d2e6f6f334dfeb5e8ae33f4460c9344ec6b1e234e7f714c7602fae72f1ca5608e12145c40a39b14d28e1d79b0dd91855493d87947407428ba4c1d87834156626 SHA512 e327d58311f74c8bb9f18b99f8d866c071166e94f43912b35eedc6062267d4cdb5842bde7c54426c751b1bb76103ec11eb8daa682772a1f71c50962811dbc694
EBUILD autopep8-1.3.2.ebuild 924 BLAKE2B 766a8bde4c2273f1cda5a80f42e1b0bab0b8a0b8efb59927897b6fe4d6c64d1c91960da28b636e530149aafbd9b836c6c1d61ed7e8c8930b1bfe2b0fcd44eba0 SHA512 f6fdc70395872297a118867f6a0aad98882ac51e1808d04a144dd5b30e8684bf50b1ba7924b5b8fa3c6cf866831d831c67fe84065163b2460242291dc8ece49f
+EBUILD autopep8-1.3.3.ebuild 926 BLAKE2B 895105ed0f167804a5084ed1579fc199ed82bfabc5387615f0dad2099aefafc64b26958e8dcc1ecf11ca45232be4a77ca16ebcad19451c3d3977c46b654a8a01 SHA512 9805a1668e9704c1816b53d61026d2e34ae27d7bfbfb9b4d3cedcc128ee60e4d9e344740d86f8c361563e9ffc7f2ad32e3abedd8b18086f3c412126b6189c898
EBUILD autopep8-9999.ebuild 727 BLAKE2B 9eb071eca08904c0bb72b084b4bca1760b59694ca503d11fbe27af4cf8f6929b77004c5c4d7967e1faaedd29b079db97c2c7b21296e223a08b6a7356ffd0349b SHA512 21692eee175575acf3521fd83331b81c522c3523458658c3409ab7ee71c9620333ff82ce3c0264ce7ccf2fb91222a88c2984972d8b997848e1bdf700cde4b2ed
MISC metadata.xml 484 BLAKE2B e99d8c92cf8d692e645db02a59bf083c14d12ae177a5acf1248961329e79fe5f1a56af05d2a942e3d644918c9f2d6e4a24d698e18441f5a65efac87ad880bed9 SHA512 7542d6e1738ad7d333fc2ef8d6072e6963dfbc07f731f3e9137e49936165ef26145185a34cdfb6dfa5df16ac4a73bff3c8e6fde8c9f0477e1545ee5e2c6b605c
diff --git a/dev-python/autopep8/autopep8-1.3.3.ebuild b/dev-python/autopep8/autopep8-1.3.3.ebuild
new file mode 100644
index 000000000000..32c6043fa952
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.3.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.python.org/pypi/autopep8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.3[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Prevent UnicodeDecodeError with LANG=C
+ sed -e "/é/d" -i MANIFEST.in || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}