summaryrefslogtreecommitdiff
path: root/dev-python/autopep8/autopep8-2.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-24 00:07:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-24 00:07:11 +0100
commitaa4954f71a3ba2293395a8cce2321a70c39c7554 (patch)
tree35665855d8a569dca2bdf52a7316e2503df68208 /dev-python/autopep8/autopep8-2.1.1.ebuild
parentb3b92de25c3fc5f6bddc5e513027140591a0b2a5 (diff)
gentoo auto-resync : 24:05:2024 - 00:07:11
Diffstat (limited to 'dev-python/autopep8/autopep8-2.1.1.ebuild')
-rw-r--r--dev-python/autopep8/autopep8-2.1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/autopep8/autopep8-2.1.1.ebuild b/dev-python/autopep8/autopep8-2.1.1.ebuild
new file mode 100644
index 000000000000..6a718a775d3f
--- /dev/null
+++ b/dev-python/autopep8/autopep8-2.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="
+ https://github.com/hhatto/autopep8/
+ https://pypi.org/project/autopep8/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/pycodestyle-2.11.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+distutils_enable_tests pytest