summaryrefslogtreecommitdiff
path: root/dev-python/authres/authres-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-python/authres/authres-1.1.1.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-python/authres/authres-1.1.1.ebuild')
-rw-r--r--dev-python/authres/authres-1.1.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/authres/authres-1.1.1.ebuild b/dev-python/authres/authres-1.1.1.ebuild
new file mode 100644
index 000000000000..194c7205ebfc
--- /dev/null
+++ b/dev-python/authres/authres-1.1.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Authentication-Results Headers generation and parsing"
+HOMEPAGE="https://launchpad.net/authentication-results-python https://pypi.org/project/authres/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+python_test() {
+ "${EPYTHON}" -m doctest -v authres/tests ||
+ die "Tests fail with ${EPYTHON}"
+}