summaryrefslogtreecommitdiff
path: root/dev-python/audioread
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/audioread
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/audioread')
-rw-r--r--dev-python/audioread/Manifest4
-rw-r--r--dev-python/audioread/audioread-1.0.1-r1.ebuild31
-rw-r--r--dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch30
-rw-r--r--dev-python/audioread/metadata.xml15
4 files changed, 0 insertions, 80 deletions
diff --git a/dev-python/audioread/Manifest b/dev-python/audioread/Manifest
deleted file mode 100644
index 477f5720a457..000000000000
--- a/dev-python/audioread/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX 0001-Use-the-print-function-instead-of-the-print-keyword.patch 981 BLAKE2B 5ee416ba841733ee400d8dc544d3ab4ad44389a6e23a21624cddd284493c37f6c302da33b0f21921f09dd88d9d749204757bff33f676108fe8fa39641f262273 SHA512 6dbd099bf334af6674b24b87f17d7f97d00978c5817d852608b5e835efaa988897c9713e55f04ab9e567595686459a4e5e840aba61df6bfd80d9b80d18622c8a
-DIST audioread-1.0.1.tar.gz 13004 BLAKE2B e2741e43904ab3eba821118163d019bc336fafc157c0a5ab7ccf09c2622d395da104232d5276fda32cd7e945a4b66279ee028bde502e2359fa58c210b5af7804 SHA512 18e9e696785fe2f1b1d6ad7fe64e2878bf490d72aef7500998bb48b0733b382cf0b171d26c5b1465947de1d5f6ded25e2b57947402c31a440e8f346722fdc533
-EBUILD audioread-1.0.1-r1.ebuild 772 BLAKE2B a84c59018dcd845fac68001af472934f08e991772e7377617e5154c5caec7b6c77d0521ae91a0b97d724f1869474224f94e84819118864f2a0866c7f02f49594 SHA512 289e0df6d265a9c588f1dedd9216ae7cbce6b04f7718ba16e6714f61b4142731995d14ab85a57e0b12cb6cb128e024840b60633cf7c3056ab2cbdd4c643be51e
-MISC metadata.xml 557 BLAKE2B 21c873a48491c6e80133dd86f91a958fcd766940648053eae13029d9bca47d59dd62957cf4b1c2d679b7ac7032aa2001aa4a39d9d94ec0f5296191cfa8f86924 SHA512 60c91d4241fe34a2cb8198af0974a7383dc742d71662cb51b680449c38778b8c3e9b0d7b16191319fa7665c1ce187445fc0234f70572318d2f5103182b88e5ed
diff --git a/dev-python/audioread/audioread-1.0.1-r1.ebuild b/dev-python/audioread/audioread-1.0.1-r1.ebuild
deleted file mode 100644
index b340d5ab3daf..000000000000
--- a/dev-python/audioread/audioread-1.0.1-r1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Module for decoding audio files using whichever backend is available"
-HOMEPAGE="https://pypi.org/project/audioread/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="|| ( dev-python/pymad media-video/ffmpeg )"
-
-PATCHES=(
- "${FILESDIR}/0001-Use-the-print-function-instead-of-the-print-keyword.patch"
- )
-
-pkg_postinst() {
- einfo "You might need to enable additional USE flags in backends to"
- einfo "decode some types of audio files. Priority of backends:"
- einfo " * mad"
- einfo " * ffmpeg"
-}
diff --git a/dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch b/dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch
deleted file mode 100644
index 8feb9d0ca9b6..000000000000
--- a/dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 3f86133d37d5cc5c8712730de67c23b0d33ce082 Mon Sep 17 00:00:00 2001
-From: Simon Chopin <chopin.simon@gmail.com>
-Date: Tue, 14 May 2013 12:46:50 +0200
-Subject: [PATCH] Use the print() function instead of the print keyword
-
-Python3 doesn't have the `print foo` statement.
----
- audioread/gstdec.py | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/audioread/gstdec.py b/audioread/gstdec.py
-index 78285db..fa8078f 100644
---- a/audioread/gstdec.py
-+++ b/audioread/gstdec.py
-@@ -366,8 +366,8 @@ if __name__ == '__main__':
- for path in sys.argv[1:]:
- path = os.path.abspath(os.path.expanduser(path))
- with GstAudioFile(path) as f:
-- print f.channels
-- print f.samplerate
-- print f.duration
-+ print(f.channels)
-+ print(f.samplerate)
-+ print(f.duration)
- for s in f:
-- print len(s), ord(s[0])
-+ print(len(s), ord(s[0]))
---
-1.8.1.5
-
diff --git a/dev-python/audioread/metadata.xml b/dev-python/audioread/metadata.xml
deleted file mode 100644
index 39c8bb18ab55..000000000000
--- a/dev-python/audioread/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription lang="en">
- Decode audio files using whichever backend is available. The library currently supports:
- * Gstreamer via gst-python.
- * MAD via the pymad bindings.
- * FFmpeg via its command-line interface.
- * The standard library wave and aifc modules (for WAV and AIFF files).
- </longdescription>
- <upstream>
- <remote-id type="pypi">audioread</remote-id>
- </upstream>
-</pkgmetadata>