summaryrefslogtreecommitdiff
path: root/dev-python/audioread/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/audioread/files
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/audioread/files')
-rw-r--r--dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch30
-rw-r--r--dev-python/audioread/files/audioread-2.1.8-test-deps.patch27
2 files changed, 27 insertions, 30 deletions
diff --git a/dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch b/dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch
deleted file mode 100644
index 8feb9d0ca9b6..000000000000
--- a/dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 3f86133d37d5cc5c8712730de67c23b0d33ce082 Mon Sep 17 00:00:00 2001
-From: Simon Chopin <chopin.simon@gmail.com>
-Date: Tue, 14 May 2013 12:46:50 +0200
-Subject: [PATCH] Use the print() function instead of the print keyword
-
-Python3 doesn't have the `print foo` statement.
----
- audioread/gstdec.py | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/audioread/gstdec.py b/audioread/gstdec.py
-index 78285db..fa8078f 100644
---- a/audioread/gstdec.py
-+++ b/audioread/gstdec.py
-@@ -366,8 +366,8 @@ if __name__ == '__main__':
- for path in sys.argv[1:]:
- path = os.path.abspath(os.path.expanduser(path))
- with GstAudioFile(path) as f:
-- print f.channels
-- print f.samplerate
-- print f.duration
-+ print(f.channels)
-+ print(f.samplerate)
-+ print(f.duration)
- for s in f:
-- print len(s), ord(s[0])
-+ print(len(s), ord(s[0]))
---
-1.8.1.5
-
diff --git a/dev-python/audioread/files/audioread-2.1.8-test-deps.patch b/dev-python/audioread/files/audioread-2.1.8-test-deps.patch
new file mode 100644
index 000000000000..0a67767070b1
--- /dev/null
+++ b/dev-python/audioread/files/audioread-2.1.8-test-deps.patch
@@ -0,0 +1,27 @@
+From 5dd6c87a53f3a6c5bfa6ea384598213c49402056 Mon Sep 17 00:00:00 2001
+From: Glen Baker <iepathos@gmail.com>
+Date: Mon, 5 Aug 2019 23:40:27 -0700
+Subject: [PATCH] Correct pytest-runner location in setup.py
+
+Moved pytest-runner from setup_requires to tests_require. It is the tests that require pytest-runner.
+---
+ setup.py | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index bd90605..6041f6e 100644
+--- a/setup.py
++++ b/setup.py
+@@ -36,11 +36,8 @@ def _read(fn):
+
+ packages=['audioread'],
+
+- setup_requires=[
+- 'pytest-runner'
+- ],
+-
+ tests_require=[
++ 'pytest-runner',
+ 'pytest'
+ ],
+