summaryrefslogtreecommitdiff
path: root/dev-python/audioread/audioread-2.1.8-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/audioread/audioread-2.1.8-r2.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/audioread/audioread-2.1.8-r2.ebuild')
-rw-r--r--dev-python/audioread/audioread-2.1.8-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/audioread/audioread-2.1.8-r2.ebuild b/dev-python/audioread/audioread-2.1.8-r2.ebuild
new file mode 100644
index 000000000000..ef3bc88e7429
--- /dev/null
+++ b/dev-python/audioread/audioread-2.1.8-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Wrapper for audio file decoding using FFmpeg or GStreamer"
+HOMEPAGE="https://pypi.org/project/audioread/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ffmpeg gstreamer mad test"
+
+BDEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+ ffmpeg? ( media-video/ffmpeg )
+ gstreamer? (
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ media-libs/gstreamer:1.0
+ media-plugins/gst-plugins-meta:1.0
+ )
+ mad? ( dev-python/pymad )
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}/${P}-test-deps.patch" ) # git master
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -e "/'pytest-runner'/d" -i setup.py || die
+}