summaryrefslogtreecommitdiff
path: root/dev-python/async-timeout/async-timeout-4.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-11 09:34:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-11 09:34:39 +0100
commit7e2b5bc2c2e2e045de6095d46c24ee857453adf2 (patch)
tree4387abc7e6be6debdd362738e7976e0d053163a1 /dev-python/async-timeout/async-timeout-4.0.3.ebuild
parent9b97cf60d2411c33c1b2170b730b345ea9995002 (diff)
gentoo auto-resync : 11:08:2023 - 09:34:39
Diffstat (limited to 'dev-python/async-timeout/async-timeout-4.0.3.ebuild')
-rw-r--r--dev-python/async-timeout/async-timeout-4.0.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/async-timeout/async-timeout-4.0.3.ebuild b/dev-python/async-timeout/async-timeout-4.0.3.ebuild
new file mode 100644
index 000000000000..eecb20bd7fc1
--- /dev/null
+++ b/dev-python/async-timeout/async-timeout-4.0.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Timeout context manager for asyncio programs"
+HOMEPAGE="
+ https://github.com/aio-libs/async-timeout/
+ https://pypi.org/project/async-timeout/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -p asyncio
+}