summaryrefslogtreecommitdiff
path: root/dev-python/astroml-addons
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/astroml-addons
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/astroml-addons')
-rw-r--r--dev-python/astroml-addons/Manifest4
-rw-r--r--dev-python/astroml-addons/astroml-addons-0.2.2.ebuild28
-rw-r--r--dev-python/astroml-addons/metadata.xml23
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/astroml-addons/Manifest b/dev-python/astroml-addons/Manifest
new file mode 100644
index 000000000000..21a221c27131
--- /dev/null
+++ b/dev-python/astroml-addons/Manifest
@@ -0,0 +1,4 @@
+DIST astroML_addons-0.2.2.tar.gz 51052 SHA256 c4b6e9d9f86550e1a59b54ddedf6666c7293bd7ad7b99549170e3053e57cb0cb SHA512 97c61c731d3dd8cadbfcb36defd1a678f776a2012fda1159621d3e364e25ca74cd0d284980f52095a2df31973cefba09f9b3efe72ba95b4f65ca13e4aaec5e20 WHIRLPOOL d8c7650692cbbb90f4f820804603dfdc87f5bb063ff0a1977f51c0f4c40313c4a98c50385027e35ce01ed9f02b59cc009f081c8da168397f2bb141c4f867262c
+EBUILD astroml-addons-0.2.2.ebuild 640 SHA256 b4a65d85a631178ac7cc3eaf22b54776fe6d64eb5b3aa1c70634b1c25288f8df SHA512 f5335a9f9a54fa49e1f84c6febe5c9d16e037035ddf5ff4baea176ac21db9d8f8c93c6064c20b4b8d8dad2f2fe396f4d66cf40cb4f3c311ef8522df10aab1cb9 WHIRLPOOL 445a12e8c95ff6753723d4f8abcf759f390f0b64dd1b9cfd79035afdf5980fba1c2fea6554567d4255be3ecfa90dbde98766385adf7d63307cea30f02c952469
+MISC ChangeLog 337 SHA256 926a88cc31c7f3be79a54a7710666f0aaa068a5202bb9748602c0acf068768e0 SHA512 4afec5cd66da7d0637e8beb8d4aa5a8834f52181525f6740cd0702d34bac3aa3a0b96e0713d1060c0e5d3669149989b6c8e01e7649a437800ae3a3e250c7a286 WHIRLPOOL 87780f77951dfccdd22887c7444967471144c955d24a7afd7ae48cb070d23d6eadbc0862d7221a1bc0d6cf53ff739504a8255637756e1b573759e9f14951eea6
+MISC metadata.xml 1161 SHA256 41bfbe4b0480700f44dafd1c2eb8b15bc622f94711803f461f011b8e7a107be2 SHA512 3010f13652915ec0a1daca8a0bf090e7e9e7522485080492b3fd932b2154752d56c95a586ec693bca1f6c6062e8c49e35336daf987b9119c5c97c1a8350f64e4 WHIRLPOOL bae64183c007f1af7f7c58af5e0585c4a975640314af044e89fc6f502df7b9527ea4c06d62d421337a56245b17934d34f8f06aa23c3b8620ef4b278cbc97797e
diff --git a/dev-python/astroml-addons/astroml-addons-0.2.2.ebuild b/dev-python/astroml-addons/astroml-addons-0.2.2.ebuild
new file mode 100644
index 000000000000..a5b8f5357a63
--- /dev/null
+++ b/dev-python/astroml-addons/astroml-addons-0.2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MYPN=astroML_addons
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="Performance add-ons for the astroML package"
+HOMEPAGE="https://github.com/astroML/astroML_addons"
+SRC_URI="mirror://pypi/${PN:0:1}/${MYPN}/${MYP}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/astroml[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MYP}"
+
+DOCS=( README.rst )
diff --git a/dev-python/astroml-addons/metadata.xml b/dev-python/astroml-addons/metadata.xml
new file mode 100644
index 000000000000..c9e92bac1f13
--- /dev/null
+++ b/dev-python/astroml-addons/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ astroML is split into two components. The core astroML library is written
+ in python only, and is designed to be very easy to install for any users,
+ even those who don't have a working C or fortran compiler. A companion library,
+ astroML_addons, can be optionally installed for increased performance on
+ certain algorithms. Every algorithm in astroML_addons has a pure python
+ counterpart in the core astroML implementation, but the astroML_addons library
+ contains faster and more efficient implementations in compiled code.
+ Furthermore, if astroML_addons is installed on your system, the core astroML
+ library will import and use the faster routines by default.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">astroML_addons</remote-id>
+ <remote-id type="github">astroML/astroML_addons</remote-id>
+ </upstream>
+</pkgmetadata>