summaryrefslogtreecommitdiff
path: root/dev-python/astroid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-24 05:21:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-24 05:21:45 +0100
commitfcf991edcc1b310199e4e829a3706bc1c267d1db (patch)
tree50f02cb76c2666dbe78d927799c034715582c9cd /dev-python/astroid
parent3c246ed172bd795a519ba659ba32c9e91f6bedde (diff)
gentoo auto-resync : 24:09:2023 - 05:21:45
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest2
-rw-r--r--dev-python/astroid/astroid-2.15.7.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index 008bd401b429..400ae2248f85 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -1,3 +1,5 @@
DIST astroid-2.15.6.gh.tar.gz 462156 BLAKE2B f5df204a0b635d29165da1566afd9259ff26102fef3b56685ad9e10fe1cdae35aa90b1e1f81293e591c03122e980936dfd91b521dfe7a4c8cfacb8b40bcac9d6 SHA512 20c4d316176b84d61b5f44823026926e84c7de3c3a6febaa23cf9c8c5a9507ce65168804a61cb2db0ffcc7ec0ecb687282e6c794485135203cc25d30064e0047
+DIST astroid-2.15.7.gh.tar.gz 462906 BLAKE2B 7a984f9f7c67c2956958b23ee2ca94c1f86284d8a50aaedbe10b9dca887802189cba21f19ee66b394f347f415d61946aaff52e4d0448271edba77b6bd958fa0e SHA512 716665744915d8a635ac124f03ffe6f7aee6bde6d98c238551ea1c6468595d6c327bb2d5605f66e7ba6294ec1b79c85b861034acba8a4584095ba38e24f82ae9
EBUILD astroid-2.15.6.ebuild 2128 BLAKE2B 01f6d4c0ad79f509c1a83768c95600d88c664deba854d6918ba1fa0af5872bd31fd6529f242d2b04423b83d852016bec866fb97be54b823ac3b97b067ee48854 SHA512 57cd191f718ddf5e0e90b8781b2eca9b6c91dca1821b1a95763e0b574a645ab6c5cdbfa91ea202a194799cc52d697b534d01786e9d98302dd85ce79d8dc5576e
+EBUILD astroid-2.15.7.ebuild 2136 BLAKE2B 07a254757a59744bac016b0c148c52825406021366d0fbebf398f7df8d8e83fb006c1c261554b48c97e471f5abd6f8dbbcd7bf8723b66ad752a9adbb4dbff03b SHA512 da3f7f8a053872d3745957d9cd23e30b26ec4858dd3847d70e41318980256ea802f3ca3fd511d8a36254022a6d7639841c74d68c65368a64cf475cf9574dde0a
MISC metadata.xml 1148 BLAKE2B 29a6cfc0c292117920be154d37ed4770f1fb1679186576fe6151cc02d1d6be766045e0231e2fceb87cbd250dbed3888c99b7ca7dc0182cc700a11961d9cd6d9e SHA512 6821d13f5e82bd73ee4fd165c0b4c94f40cd6af536dee1658cccb4175e67da2611c4d1478cdef1607535f23224116ad482197e0b0eef8f0a94d596bf250b3074
diff --git a/dev-python/astroid/astroid-2.15.7.ebuild b/dev-python/astroid/astroid-2.15.7.ebuild
new file mode 100644
index 000000000000..d2feb47f4808
--- /dev/null
+++ b/dev-python/astroid/astroid-2.15.7.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="
+ https://github.com/pylint-dev/astroid/
+ https://pypi.org/project/astroid/
+"
+SRC_URI="
+ https://github.com/pylint-dev/astroid/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Version specified in pyproject.toml
+RDEPEND="
+ >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ <dev-python/wrapt-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # no clue why they're broken
+ tests/test_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
+ tests/test_regrtest.py::NonRegressionTests::test_numpy_distutils
+ tests/brain/test_regex.py::TestRegexBrain::test_regex_pattern_and_match_subscriptable
+ # some problem with warnings (our options?)
+ tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_one_arg
+ tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_two_args
+ tests/test_scoped_nodes.py::test_deprecation_of_doc_attribute
+ # requires six bundled in urllib3, sigh
+ tests/test_modutils.py::test_file_info_from_modpath__SixMetaPathImporter
+ # requires pip, and looks suspicious anyway
+ tests/test_manager.py::IsolatedAstroidManagerTest::test_no_user_warning
+ # pydantic-2?
+ tests/brain/test_dataclasses.py::test_pydantic_field
+ )
+
+ # Faker causes sys.path_importer_cache keys to be overwritten
+ # with PosixPaths
+ epytest -p no:faker
+}