summaryrefslogtreecommitdiff
path: root/dev-python/astroid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-12 17:29:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-12 17:29:30 +0000
commit3bcdaa6f06fae7659c3ac8294503c45e6736a2e1 (patch)
treebacdf1ca962c5d980cb299e02560868f426efcf1 /dev-python/astroid
parentc9818073ff1b4fa99a5b484aa5f5e02d4aa487b9 (diff)
gentoo auto-resync : 12:12:2023 - 17:29:30
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest2
-rw-r--r--dev-python/astroid/astroid-3.0.2.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index 3a31b6da5561..6b1c28ecba24 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -1,3 +1,5 @@
DIST astroid-3.0.1.gh.tar.gz 461593 BLAKE2B de3458bcd9ba111020132e89b6e2fdf18b81b82cba68c986e84af91c910e6c70e7d13ff024b7947f3fa08e2491ba211a77a35421b3d5cd184b94e6a833c0da42 SHA512 2c8a4cf22959aef1eb9510430bcc55d00fcda76d022575786c9a59c093fe4196b67c0b9401f9226595a4cbf1fb9444bdfbb9ac2d83c115ec1d7d46cb7dd75dbd
+DIST astroid-3.0.2.gh.tar.gz 461786 BLAKE2B d005fe36e6d7dc4bfc7388f1d4ac52c4602f7c18accfacbeb55545b382fe5e16ef7cedd493aef5413b57a5ac872807b8d9857fc02a7b4053edd54780814f64e8 SHA512 88fa6ff9c66f5224113001c4911cbe2f3055b990c5d0b3ac206166575d7fd5b7fae99fa67a655703d7868ee8c47841ece8b2c2d44712b1fdaf39fa26f786815f
EBUILD astroid-3.0.1.ebuild 1523 BLAKE2B b6bab837ed6c25bf19cc97de9195a26097506157467d76e89c1362c7ccdcfc6d546f61526c3b01efe9f1894b35dc695f1db0713f2bc17806cecfc779c289232e SHA512 b30cfebf27e79a108d2ed1932d0427e9a813fda8312339b79f4b18e2aa46d977128600a5226f2b243102906e67371c5670d15f7ac9c50a1d5cd915897172a401
+EBUILD astroid-3.0.2.ebuild 1531 BLAKE2B 4f3eef3aa5223b147ac7c3b7b20f1f8549c3c4e8ca4e8a3129332f8cad4167487e3717ebd33a1a60fc6de1f6f9b53790e09c2885d4a2647a0912062f0fee7e2c SHA512 a6bffc14c19e95619dca959244d9d5e1c1fd79748de7398c70cf813914df0b71edd50c02b87f8050dcc380a068aa39dee63af6b42f3e2e2b7be023763c4436a2
MISC metadata.xml 1148 BLAKE2B 29a6cfc0c292117920be154d37ed4770f1fb1679186576fe6151cc02d1d6be766045e0231e2fceb87cbd250dbed3888c99b7ca7dc0182cc700a11961d9cd6d9e SHA512 6821d13f5e82bd73ee4fd165c0b4c94f40cd6af536dee1658cccb4175e67da2611c4d1478cdef1607535f23224116ad482197e0b0eef8f0a94d596bf250b3074
diff --git a/dev-python/astroid/astroid-3.0.2.ebuild b/dev-python/astroid/astroid-3.0.2.ebuild
new file mode 100644
index 000000000000..0eb14a035bb8
--- /dev/null
+++ b/dev-python/astroid/astroid-3.0.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="
+ https://github.com/pylint-dev/astroid/
+ https://pypi.org/project/astroid/
+"
+SRC_URI="
+ https://github.com/pylint-dev/astroid/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Version specified in pyproject.toml
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.17.0[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # no clue why they're broken
+ tests/test_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
+ tests/test_regrtest.py::NonRegressionTests::test_numpy_distutils
+ # pydantic-2?
+ tests/brain/test_dataclasses.py::test_pydantic_field
+ # requires urllib3 with bundled six (skipped with urllib3>=2)
+ tests/test_modutils.py::test_file_info_from_modpath__SixMetaPathImporter
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}