summaryrefslogtreecommitdiff
path: root/dev-python/astroid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-07 06:12:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-07 06:12:40 +0000
commitff3ac0b17b39e52a4fc9ca04d17a5535c8f6085c (patch)
tree71efa15498950476bf57b0f5c1d158d9ee985071 /dev-python/astroid
parent86bac35ed1b4f7018bc03aea5551f7664a2b9ff4 (diff)
gentoo auto-resync : 07:01:2023 - 06:12:40
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest2
-rw-r--r--dev-python/astroid/astroid-2.12.14.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index 2685565adfa3..6c3fceaa3fc0 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -1,3 +1,5 @@
DIST astroid-2.12.13.gh.tar.gz 437906 BLAKE2B c00462d44c9705dc5b46fc52915e6a44e53e840d5326427d235c9156bc4de58b184271338ebc10a4572e1aace8d4ababd3bd7e440a6ee585aa66d15dfe4117be SHA512 16d062b1a619663b157c4753f1744e56e7d0ef7cace12660feb7f6bc540e54be02638b52c1c877d3eb514e2d7423c4afc71e7d5464880bfd3724ff7ae6d7b90a
+DIST astroid-2.12.14.gh.tar.gz 440473 BLAKE2B 5b3d55664676b806af73208a2fcbbea2ee0c48bfb59ffa4f54fdc6dd35463d032b4b033530c9d10c52289f3d51c8d59c4d35330a427110c76a1a4566162ceddc SHA512 cdce9ed35ec107bb7ed4a7eb9e778f90c248dbbc00e3da5b4ae86340f960b71f31ffea0cabb677f17bde9daa28f8bed1de4a9f331b8cc975d85793a44dc29b65
EBUILD astroid-2.12.13.ebuild 1816 BLAKE2B f1f21f45a5b36043905eebd5153754d0a4feb88b05813052898b70379ddbb7350be1440a8a7fec3209f1a664f71dd83e46948283314fa1697e2189ac12d4ef65 SHA512 5042ae5ad74caa9736d55880f623e6d73893de397bf1e594dac9efef4858320ccaecb26c9fbe8fdf905c8c9612a995795af7b7f7c949fe83f8a3c73046577760
+EBUILD astroid-2.12.14.ebuild 1824 BLAKE2B 9644ee13a4da0148a7150e579e110d37117b7c85d679aafac6a7cc99b13c17263eaa1349bb32e1e987e329daca30ef6814689eb5e528be6e2f14231dd4ca45c5 SHA512 177e95f9b017004667b2db9fbeb2e2ed3d957ef83516a77660adfa7ac8550aabd3a752bad5801cbea6d7312b73ce445504f97852a59dd85588151f9fcc8e4742
MISC metadata.xml 1143 BLAKE2B 1f6c4e004277eebed2e29cb935ef01e5f18fb0a526f99f0e875ae3815308dce0483b5274b4e23bed076464aa62a035937a7a3817e2d4a5fb9211b9043271e04c SHA512 56b07d0f08a49772661bc3d233cf1f628aa7c241c51b91d75dfbd44995e169d8ab5bbd99863d7b9b67792486346982a7b8eebefb462e7e212cd7dff920d80840
diff --git a/dev-python/astroid/astroid-2.12.14.ebuild b/dev-python/astroid/astroid-2.12.14.ebuild
new file mode 100644
index 000000000000..4dc5cb9edc30
--- /dev/null
+++ b/dev-python/astroid/astroid-2.12.14.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="
+ https://github.com/PyCQA/astroid/
+ https://pypi.org/project/astroid/
+"
+SRC_URI="
+ https://github.com/PyCQA/astroid/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Version specified in pyproject.toml
+RDEPEND="
+ >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.10[${PYTHON_USEDEP}]
+ <dev-python/wrapt-2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # no clue why it's broken
+ tests/unittest_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
+ tests/unittest_brain_dataclasses.py::test_pydantic_field
+ tests/unittest_brain.py::SixBrainTest::test_from_imports
+ tests/unittest_regrtest.py::NonRegressionTests::test_numpy_distutils
+ # some problem with warnings (our options?)
+ tests/unittest_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_one_arg
+ tests/unittest_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_two_args
+ tests/unittest_scoped_nodes.py::test_deprecation_of_doc_attribute
+ )
+
+ # Faker causes sys.path_importer_cache keys to be overwritten
+ # with PosixPaths
+ epytest -p no:faker
+}