summaryrefslogtreecommitdiff
path: root/dev-python/astroid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-15 10:03:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-15 10:03:16 +0100
commitd57892fd8c8d84b85e73005a433f66d85da12fa3 (patch)
tree6f735debac848918a243f90ae2fa6a2fb69e77ad /dev-python/astroid
parent4a7e8a04f36caa88d1996b1dcdedb196bb4beb2f (diff)
gentoo auto-resync : 15:05:2023 - 10:03:16
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest2
-rw-r--r--dev-python/astroid/astroid-2.15.5.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index d155084b79a6..e79836708aa6 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -1,3 +1,5 @@
DIST astroid-2.15.4.gh.tar.gz 461609 BLAKE2B 0dc54a0a99c16698e025f01361d67a5aa248e091f757184bfeb8b6287d656afbb56706a99058c0105252c6925dbe51e8ee260020d7512d7aa9bbf3d92d0a0b7e SHA512 1725676cd55fde0359e7210b917663fa82a87bbec052fda27a80a08e7d2308ab1de7a5c1f1a052fd76575d9945d55743e6c23684754e03e84bb2facb51f2a5a2
+DIST astroid-2.15.5.gh.tar.gz 461755 BLAKE2B 4af28becb14d767c3fa162be93cd1d3f99e42a476a7b1ee57225a6d5603876cbfde7a58e17412d1142baa42288cbb2cfe3ecdbaafe5195c777f04a3ad9fe4427 SHA512 9862a2f4703b36284d14a3b09f80b4b0a1e0948e306b4906ec663fc133d07966e24a711a90067b369b166ce4d53859327e1da84406a023d1a911fff7bb0ed026
EBUILD astroid-2.15.4.ebuild 2056 BLAKE2B 84fa5ec7453a6d38e3fa2ee8064322d0e2db5b739814ab33ac71f83a6d1ea7ee61ff909ebd1ccb7ccbb8729ce95223d1d7cdd94c38d0e4f252a1274161d07277 SHA512 913d03026a52671360116f2e29386207470ec68eee96273117ef4f17c46f5d537cdf3b1120181ac6d8c4db22ade9f6ead702f253419ade69f7241e6d0fb70d88
+EBUILD astroid-2.15.5.ebuild 2064 BLAKE2B 4d0a944a806aa5a6a9696737a20e1c79475eecb027c39572a99de94ea137dea4d43bfccfbf1a475552fc2979fb6c13f1266c252a150e24e3b0d75b28b211c2c0 SHA512 e349c61c5588290e1b7a8b1b991cc5ee1c0c34d2973453e4fb7b6ead0ac878016489132dbf45068247713ab073971554727d8fb292041a88ffe6ecd6a39c5c60
MISC metadata.xml 1148 BLAKE2B 29a6cfc0c292117920be154d37ed4770f1fb1679186576fe6151cc02d1d6be766045e0231e2fceb87cbd250dbed3888c99b7ca7dc0182cc700a11961d9cd6d9e SHA512 6821d13f5e82bd73ee4fd165c0b4c94f40cd6af536dee1658cccb4175e67da2611c4d1478cdef1607535f23224116ad482197e0b0eef8f0a94d596bf250b3074
diff --git a/dev-python/astroid/astroid-2.15.5.ebuild b/dev-python/astroid/astroid-2.15.5.ebuild
new file mode 100644
index 000000000000..553be35505ca
--- /dev/null
+++ b/dev-python/astroid/astroid-2.15.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="
+ https://github.com/pylint-dev/astroid/
+ https://pypi.org/project/astroid/
+"
+SRC_URI="
+ https://github.com/pylint-dev/astroid/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Version specified in pyproject.toml
+RDEPEND="
+ >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ <dev-python/wrapt-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # no clue why they're broken
+ tests/test_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
+ tests/test_regrtest.py::NonRegressionTests::test_numpy_distutils
+ tests/brain/test_regex.py::TestRegexBrain::test_regex_pattern_and_match_subscriptable
+ # some problem with warnings (our options?)
+ tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_one_arg
+ tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_two_args
+ tests/test_scoped_nodes.py::test_deprecation_of_doc_attribute
+ # requires six bundled in urllib3, sigh
+ tests/test_modutils.py::test_file_info_from_modpath__SixMetaPathImporter
+ # requires pip, and looks suspicious anyway
+ tests/test_manager.py::IsolatedAstroidManagerTest::test_no_user_warning
+ )
+
+ # Faker causes sys.path_importer_cache keys to be overwritten
+ # with PosixPaths
+ epytest -p no:faker
+}