summaryrefslogtreecommitdiff
path: root/dev-python/astroid/astroid-1.5.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/astroid/astroid-1.5.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/astroid/astroid-1.5.2-r1.ebuild')
-rw-r--r--dev-python/astroid/astroid-1.5.2-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/astroid/astroid-1.5.2-r1.ebuild b/dev-python/astroid/astroid-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..971e558cca36
--- /dev/null
+++ b/dev-python/astroid/astroid-1.5.2-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="https://bitbucket.org/logilab/astroid https://pypi.python.org/pypi/astroid"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x64-macos ~x86-macos"
+IUSE="test"
+
+# Version specified in __pkginfo__.py.
+RDEPEND="
+ dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' -2)"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' 'python*')
+ >=dev-python/pylint-1.6.0[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Disable failing tests
+ # TODO: investigate if it's our fault and how can we fix it
+ sed -i -e "s/test_namespace_package_pth_support/_&/" \
+ astroid/tests/unittest_manager.py || die
+ # we hack xml module, so it does not match what they expect...
+ sed -i -e "s/test_module_model/_&/" \
+ astroid/tests/unittest_object_model.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${EPYTHON} -m unittest discover -p "unittest*.py" --verbose || die
+}