summaryrefslogtreecommitdiff
path: root/dev-python/astor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/astor
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/astor')
-rw-r--r--dev-python/astor/Manifest5
-rw-r--r--dev-python/astor/astor-0.5.ebuild28
-rw-r--r--dev-python/astor/astor-0.6.ebuild28
-rw-r--r--dev-python/astor/metadata.xml11
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/astor/Manifest b/dev-python/astor/Manifest
new file mode 100644
index 000000000000..1336ce3805f7
--- /dev/null
+++ b/dev-python/astor/Manifest
@@ -0,0 +1,5 @@
+DIST astor-0.5.tar.gz 10999 BLAKE2B 278bf193003dd9f8f2d5c6a33229e3f4013bcf0618dee1d8cc3891ffea031f63ad4f795a3b66e87986bcf377b5f81eb6992d3c47c2234357487443a049d45d31 SHA512 7c940371a6c3ddbc4a6691edb6ee17eef61436912bb873c5c0cba4f3865c9d4f8e077674b14ccc7e319b749898782aaf87e085eedd9ba7f8638130deb67f549b
+DIST astor-0.6.tar.gz 28684 BLAKE2B 372314e0d92721d3cbb7fe0fe8bc42635e023ca590c4845c8e7c499bc947c3de0a3679fff51a07085d26bca37e83301ef9c0b66548b929a8f018760c8370319c SHA512 4f9598229f8a77901573fa1841716cc810ec8e108b155d8c7c50ab477d794f8ecd1784df66a1272a2739cc968d8eb6632f62b4d6ef067682db05233f127be409
+EBUILD astor-0.5.ebuild 707 BLAKE2B ad362c0b465e650aa8a2278c4f5cb5252d7cd3bd60d80b94b472c2a51cb73b56113e03a56da08e145770b017ec3452c680c530e3b2212504dbe751fbd38cdfc9 SHA512 fb87e5af182b24a425d9e088543bb07ba2ad415c6420333fa4af1911e9d44a042838e86fefcfc775347ab0ba100458dd8f64e4e0d4383d64c9c6ffbc9998304d
+EBUILD astor-0.6.ebuild 709 BLAKE2B 816f3c4db33daad14a4e7f568a8895c6c6ef1ac895c2e263a002e8dbc9afb7a2a21dc2a91fa49cad90a7f7a90b2828ead4bfd6501566c42280ebcfb25923264a SHA512 6bb146ab91dd7e43abd6204f8b349e1ce44f69ff6352a805e32cc2bfa03b09f9e2c67cee8fcb32350b653474f80ff54183d11d2b6f49b9da196a6927ee837c47
+MISC metadata.xml 308 BLAKE2B 4eb385f663046756ae848b87d82301e3d2ddf388eae73431024dbf4758c5d4787f879ad167eda72ae011ab41cebc48718fc40a5ed86f3d382dea6165baf1a3cc SHA512 86cbc23c8c077f9849004214ba32c5096e64ea8092ff1940f3fb4c9bf4fd420f2883aed76a7b96774f639cb98ef14429a9e55993db07173443ee16b3ac393aab
diff --git a/dev-python/astor/astor-0.5.ebuild b/dev-python/astor/astor-0.5.ebuild
new file mode 100644
index 000000000000..20ad333455a4
--- /dev/null
+++ b/dev-python/astor/astor-0.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Read/rewrite/write Python ASTs"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="https://pypi.org/project/astor/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ #avoid file collisions picked up by the eclass
+ sed -e s":find_packages():find_packages(exclude=['tests']):" -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/astor/astor-0.6.ebuild b/dev-python/astor/astor-0.6.ebuild
new file mode 100644
index 000000000000..836a2d1f34e6
--- /dev/null
+++ b/dev-python/astor/astor-0.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Read/rewrite/write Python ASTs"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="https://pypi.org/project/astor/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ #avoid file collisions picked up by the eclass
+ sed -e s":find_packages():find_packages(exclude=['tests']):" -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/astor/metadata.xml b/dev-python/astor/metadata.xml
new file mode 100644
index 000000000000..d860d8c96b03
--- /dev/null
+++ b/dev-python/astor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">astor</remote-id>
+ </upstream>
+</pkgmetadata>