summaryrefslogtreecommitdiff
path: root/dev-python/asteval/asteval-0.9.28.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-08 09:23:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-08 09:23:49 +0000
commitf077c725ef746943ec7902350b30ff569f5995ba (patch)
treeac5ad0215e09a9daa3ce0e55095401ead1936ac8 /dev-python/asteval/asteval-0.9.28.ebuild
parentb6cda9acfebad17184578dfebaf2434ef2884883 (diff)
gentoo auto-resync : 08:11:2022 - 09:23:49
Diffstat (limited to 'dev-python/asteval/asteval-0.9.28.ebuild')
-rw-r--r--dev-python/asteval/asteval-0.9.28.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/asteval/asteval-0.9.28.ebuild b/dev-python/asteval/asteval-0.9.28.ebuild
new file mode 100644
index 000000000000..f2a91b2237be
--- /dev/null
+++ b/dev-python/asteval/asteval-0.9.28.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Evaluator of Python expression using ast module"
+HOMEPAGE="
+ https://newville.github.io/asteval/
+ https://github.com/newville/asteval/
+ https://pypi.org/project/asteval/
+"
+SRC_URI="
+ https://github.com/newville/asteval/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ epytest -o addopts=
+}