summaryrefslogtreecommitdiff
path: root/dev-python/arrow/arrow-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-01 05:41:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-01 05:41:49 +0100
commit9a92076d428b51966bd8d699427341e5500b3a8a (patch)
tree89cfb1b8eafec7472c5c70e3b2d47f5372fa067a /dev-python/arrow/arrow-1.3.0.ebuild
parentacc3fd0021f478ed04cb72c7b46bc0d6fa315f29 (diff)
gentoo auto-resync : 01:10:2023 - 05:41:49
Diffstat (limited to 'dev-python/arrow/arrow-1.3.0.ebuild')
-rw-r--r--dev-python/arrow/arrow-1.3.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/arrow/arrow-1.3.0.ebuild b/dev-python/arrow/arrow-1.3.0.ebuild
new file mode 100644
index 000000000000..b77f1acf1f27
--- /dev/null
+++ b/dev-python/arrow/arrow-1.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Better dates and times for Python"
+HOMEPAGE="
+ https://github.com/arrow-py/arrow/
+ https://pypi.org/project/arrow/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' tox.ini || die
+ # unnecessary type stub deps
+ sed -i -e '/types-/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}