summaryrefslogtreecommitdiff
path: root/dev-python/arrayterator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/arrayterator
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/arrayterator')
-rw-r--r--dev-python/arrayterator/Manifest3
-rw-r--r--dev-python/arrayterator/arrayterator-1.0.1-r1.ebuild28
-rw-r--r--dev-python/arrayterator/metadata.xml11
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/arrayterator/Manifest b/dev-python/arrayterator/Manifest
new file mode 100644
index 000000000000..c49ae4cd99bb
--- /dev/null
+++ b/dev-python/arrayterator/Manifest
@@ -0,0 +1,3 @@
+DIST arrayterator-1.0.1.tar.gz 7840 BLAKE2B 0fefab32f797f37aef37be4582f0e77ad2e07dd34102bddf763e93ac3c5843d57adf04eee547645fa5c547e3704d6a4da4e824182d55cb8201f40552203b98e5 SHA512 91d560f1aac1e64cda6feaf6ead5ab8ac59555e046760b6caa8cd80c47b7c96f032bde064eee82b9d5e287e8845afa2a17b3460c68561d8ff3c6fe7eecb69cb4
+EBUILD arrayterator-1.0.1-r1.ebuild 661 BLAKE2B d011f97ddbc86c2611bcd16f0347f3cda52f4d3b0a02ecd784ed149df4d741736ad6d6289f66085fde6b862280370e8ecd5d6ebc38d0a59eeae511aa2526c54e SHA512 12413c8e7d6a93a44c7e1fb225338b19713b99fd076bee074f4a0fb4c980ed7facaeb79caab65cb275416cb50c8aeddb5ad8a37260fd5ee85b575b46872e8240
+MISC metadata.xml 315 BLAKE2B 06b10d9d9f1f9ec60d97c5d42392b403ce4f76674cfb96eea3e832189476f5b5160428017db5e49da2eda7ba294a588a56deb601a3d75fe36d4797b740a67e70 SHA512 ffe338d470a70adefae552059ffae9658594cb62a5dd946c3616286bf53963a3116ce0f1c5ec1aeb65753cd2dc8544db192a7a80c2039f0bfd839113fa026289
diff --git a/dev-python/arrayterator/arrayterator-1.0.1-r1.ebuild b/dev-python/arrayterator/arrayterator-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..b4299a09a288
--- /dev/null
+++ b/dev-python/arrayterator/arrayterator-1.0.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A buffered iterator for reading big arrays in small contiguous blocks"
+HOMEPAGE="https://pypi.org/project/arrayterator/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+RDEPEND=">=dev-python/numpy-1.0_rc1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ cd tests || die
+
+ "${PYTHON}" -c "import test_stochastic; test_stochastic.test()" \
+ || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/arrayterator/metadata.xml b/dev-python/arrayterator/metadata.xml
new file mode 100644
index 000000000000..b7763250cf5a
--- /dev/null
+++ b/dev-python/arrayterator/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">arrayterator</remote-id>
+ </upstream>
+</pkgmetadata>