summaryrefslogtreecommitdiff
path: root/dev-python/argon2-cffi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /dev-python/argon2-cffi
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'dev-python/argon2-cffi')
-rw-r--r--dev-python/argon2-cffi/Manifest3
-rw-r--r--dev-python/argon2-cffi/argon2-cffi-20.1.0.ebuild35
-rw-r--r--dev-python/argon2-cffi/metadata.xml20
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/argon2-cffi/Manifest b/dev-python/argon2-cffi/Manifest
new file mode 100644
index 000000000000..ac5ebc0984dd
--- /dev/null
+++ b/dev-python/argon2-cffi/Manifest
@@ -0,0 +1,3 @@
+DIST argon2-cffi-20.1.0.tar.gz 1814415 BLAKE2B c216349beffa263fd96df23f40a8102b56a88b8320e64ac062ecfea4582efa34b298ba223437bfbfc422b68a3d9b9ea769c384db078c633103f2aae3cd38bd5b SHA512 d1d798e3e51ed67c4f523a66081fea99479ee986b5cfc36b250954e757b9846625681445447f9347519d9988f8a2ace2e3c8ce5817c5c6b4767819cf56ee0af2
+EBUILD argon2-cffi-20.1.0.ebuild 754 BLAKE2B 6d1a5af93bf210b9b9b34212ff9498078c97873e418556ec527f281daf918554a4977475f2e1012e287d77e52afa1ffccc4d9cdd27bb0ec6684d03c138b6b776 SHA512 e13ac8ec2b0f9927fb20670c6acfb94733d4e2caec97db5a8e6f04d0da734a0d70b9423da7f359e6f2bc541085d678d3b90258727c84d421782d361aae3038e3
+MISC metadata.xml 635 BLAKE2B f81f4a8996795ecf69d31587e460532fca7861c8bc5546c7511ee19389406601e0cfe84d67e9387163247833f4032c8c00f3c4de7fcdf8b9f4a0ff405a5299b5 SHA512 d50d5dbcf728218f7fa3accb7b105b6c879a0fef1382868a1d30159e91dcbb3aa818e986303c0c694ac3d8b00b53e17a66d6b9c9d69bfa8a8d20157cacd5f706
diff --git a/dev-python/argon2-cffi/argon2-cffi-20.1.0.ebuild b/dev-python/argon2-cffi/argon2-cffi-20.1.0.ebuild
new file mode 100644
index 000000000000..fd169244b16c
--- /dev/null
+++ b/dev-python/argon2-cffi/argon2-cffi-20.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="CFFI bindings to the Argon2 password hashing library"
+HOMEPAGE="https://github.com/hynek/argon2-cffi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ app-crypt/argon2:=
+ dev-python/six[${PYTHON_USEDEP}]
+ virtual/python-cffi[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst FAQ.rst README.rst )
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_configure_all() {
+ export ARGON2_CFFI_USE_SYSTEM=1
+}
diff --git a/dev-python/argon2-cffi/metadata.xml b/dev-python/argon2-cffi/metadata.xml
new file mode 100644
index 000000000000..12d0ade52d84
--- /dev/null
+++ b/dev-python/argon2-cffi/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>m.seifert@digitalernachschub.de</email>
+ <name>Michael Seifert</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">argon2-cffi</remote-id>
+ <remote-id type="github">hynek/argon2-cffi</remote-id>
+ </upstream>
+</pkgmetadata>