summaryrefslogtreecommitdiff
path: root/dev-python/argh/argh-0.31.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-31 11:45:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-31 11:45:37 +0000
commit0f7bcc64cee796c21b0ea6af6e171e89fd33966e (patch)
tree9807c45157c7191f4a297fe4d6f93e94f74d3106 /dev-python/argh/argh-0.31.0.ebuild
parent8507777b4ede346b47aafc436295a51890b9cea3 (diff)
gentoo auto-resync : 31:12:2023 - 11:45:37
Diffstat (limited to 'dev-python/argh/argh-0.31.0.ebuild')
-rw-r--r--dev-python/argh/argh-0.31.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/argh/argh-0.31.0.ebuild b/dev-python/argh/argh-0.31.0.ebuild
new file mode 100644
index 000000000000..32a100a7ba11
--- /dev/null
+++ b/dev-python/argh/argh-0.31.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="
+ https://pythonhosted.org/argh/
+ https://github.com/neithere/argh/
+ https://pypi.org/project/argh/
+"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+LICENSE="LGPL-3"
+
+BDEPEND="
+ test? (
+ dev-python/iocapture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest