summaryrefslogtreecommitdiff
path: root/dev-python/argcomplete
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-10 11:20:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-10 11:20:21 +0000
commit92e45d8c110d3b9403a141d225037f2c8ed90450 (patch)
tree550e556281d9240286506408de04a62012fd3c5e /dev-python/argcomplete
parent8b5117492cefbaa1f87e1d83af097fd82c768674 (diff)
gentoo auto-resync : 10:12:2023 - 11:20:21
Diffstat (limited to 'dev-python/argcomplete')
-rw-r--r--dev-python/argcomplete/Manifest4
-rw-r--r--dev-python/argcomplete/argcomplete-3.2.0.ebuild43
-rw-r--r--dev-python/argcomplete/files/argcomplete-3.1.6-timeout.patch5
3 files changed, 47 insertions, 5 deletions
diff --git a/dev-python/argcomplete/Manifest b/dev-python/argcomplete/Manifest
index d67811592394..433352764b23 100644
--- a/dev-python/argcomplete/Manifest
+++ b/dev-python/argcomplete/Manifest
@@ -1,4 +1,6 @@
-AUX argcomplete-3.1.6-timeout.patch 1135 BLAKE2B f7092622acfaa4932ea9b85889f6f8767114d5f697039bee992e367e99021018e94408f4ad8d2e1421e22dfe19d764c081021a6fb78264d717843ee71a4988d4 SHA512 b56b8a24e83c9560e9a05d540b075c8274a57432a7a8f3f0d491a0a6ce7e2ac2eae54f79886d48f955fcf6fad5d074202c7ec4f3870569957be51782e1fd23ba
+AUX argcomplete-3.1.6-timeout.patch 945 BLAKE2B dcdfadbdef547d45013eee33d00166b98eb6621a55f5e399cc7d330541a95118aff4a1646a85a1351209f88ff0e74d66e2468ffcf3db7e91d44ef453cc9c73e9 SHA512 fc26fc219d88a74d49245a2d545cb8040fb773fc7a948847380d4d343f19650994771a948fce99311cab7b52b3e040cf3f58291a0ac50b4a4f262dbb28c1bf85
DIST argcomplete-3.1.6.tar.gz 79685 BLAKE2B df21d5a68a173a3c09b76d866adf949910ad775eb6c7d09d797308e87c128a6eebe173d89fc95aaa42bb87bf08e9c84aa217e8844c9fab5c680c83e07d0c7854 SHA512 7d625dfc49253281f692254a23e7fc4af155b97a7df55a0b33eba9655281702396a1119269cf80b5650885e00d75886fbdcbd85312e7ccac6d940edd6189d50e
+DIST argcomplete-3.2.0.tar.gz 80524 BLAKE2B cbe15faf0c46f761204f004a4b630efbb037444a7222c9fcd59dafa7f2d8201edade374cf70fe3a059d3681ef320942dd3b43f0984c04a2cd52fe0571dafce6c SHA512 4ec4b83f68080cf8710b7377ae377a8ae10bc54f46bdd2a825b4c04d80a8d42f63fbc04d6413e2c430d7f4024ecd42f944b102c70e3fa3b60afda10a33994ac7
EBUILD argcomplete-3.1.6.ebuild 1046 BLAKE2B 4e7a38655c77c30d4f5b9678c30690a9c70747da7bb170657f3ea1b36787cf7ccaf332f165c33deeb3e684c47ed2906222d5bc321fff5489e1049537bae08fad SHA512 56d7d0a8b7972c1a4715afdd6e9ed3cfa8a5bd0b65082c8cf4df41f40570a8c44e3bf0796cd5531ae0cc35e9639a2254fc3e49d3d1558038a5ac2424d1f5be3b
+EBUILD argcomplete-3.2.0.ebuild 1054 BLAKE2B a0a67c2a3e8a8440eca5514d912376b345f46a4e2c0a261c1f2a04f1999c0f6ee773f8828f73af26055b755ebea4dd03624f25a9f4151fb179ec577734db7d00 SHA512 74c9edb59e5f919f6cb97edcd13a95a171656b2aeb2369a85b54aa5ee6f6a3de1988bee2584e2c016fce505e9980b315d37f26e42ff3a329c376efef7b05a368
MISC metadata.xml 411 BLAKE2B 963cfdba9183fde9e97c534345164d26be569d841dcc6fd274601b18d5de2ae97fa837b0acfdc59616c5d19cc54ea368547ffd901f90239cdfb5ba08e8721607 SHA512 22db237979be34053ad7201f599d576a7756b71e6b75c40c2808d47f276cce6d3594ae46dcaec5aa5adab9e9e24e11d47bb9044a8b1a146163d66687965cf5b7
diff --git a/dev-python/argcomplete/argcomplete-3.2.0.ebuild b/dev-python/argcomplete/argcomplete-3.2.0.ebuild
new file mode 100644
index 000000000000..691d9d9b7d84
--- /dev/null
+++ b/dev-python/argcomplete/argcomplete-3.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Bash tab completion for argparse"
+HOMEPAGE="
+ https://github.com/kislyuk/argcomplete/
+ https://pypi.org/project/argcomplete/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# pip is called as an external tool
+BDEPEND="
+ test? (
+ app-shells/fish
+ app-shells/tcsh
+ app-shells/zsh
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pip-19
+ )
+"
+
+PATCHES=(
+ # increase test timeouts -- this is particularly necessary
+ # for entry point tests because they read metadata of all installed
+ # packages which can take real long on systems with lots of packages
+ "${FILESDIR}/argcomplete-3.1.6-timeout.patch"
+)
+
+python_test() {
+ "${EPYTHON}" test/test.py -v || die
+}
diff --git a/dev-python/argcomplete/files/argcomplete-3.1.6-timeout.patch b/dev-python/argcomplete/files/argcomplete-3.1.6-timeout.patch
index d8348818164d..0b2ac120402e 100644
--- a/dev-python/argcomplete/files/argcomplete-3.1.6-timeout.patch
+++ b/dev-python/argcomplete/files/argcomplete-3.1.6-timeout.patch
@@ -2,10 +2,7 @@ diff --git a/test/test.py b/test/test.py
index c89912a..eedfe36 100755
--- a/test/test.py
+++ b/test/test.py
-@@ -1359,7 +1359,7 @@ class TestBashGlobal(TestBash):
- if sys.platform == "darwin":
- # Work around https://stackoverflow.com/questions/24257803
- command += ' --install-option="--prefix="'
+@@ -1362,4 +1362,4 @@ class TestBashGlobal(TestBash):
- install_output = self.sh.run_command(command)
+ install_output = self.sh.run_command(command, timeout=300)
self.assertEqual(self.sh.run_command("echo $?"), "0\r\n", install_output)