summaryrefslogtreecommitdiff
path: root/dev-python/argcomplete/argcomplete-1.11.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/argcomplete/argcomplete-1.11.1.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/argcomplete/argcomplete-1.11.1.ebuild')
-rw-r--r--dev-python/argcomplete/argcomplete-1.11.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/argcomplete/argcomplete-1.11.1.ebuild b/dev-python/argcomplete/argcomplete-1.11.1.ebuild
new file mode 100644
index 000000000000..4fadb22776fc
--- /dev/null
+++ b/dev-python/argcomplete/argcomplete-1.11.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Bash tab completion for argparse"
+HOMEPAGE="https://pypi.org/project/argcomplete/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ <dev-python/importlib_metadata-2[${PYTHON_USEDEP}]
+ ' -2 python3_{5,6,7} pypy3)"
+# pip is called as an external tool
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-shells/fish
+ app-shells/tcsh
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pip
+ )"
+
+python_test() {
+ "${EPYTHON}" test/test.py -v || die
+}