summaryrefslogtreecommitdiff
path: root/dev-python/apsw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/apsw
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/Manifest2
-rw-r--r--dev-python/apsw/apsw-3.35.4_p1.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index 4c90089f79a2..9e3bc2923af7 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -1,4 +1,6 @@
AUX apsw-3.6.20.1-fix_tests.patch 340 BLAKE2B c70f404afaed26c92f60690820812fb0ccbe355f43384b4e0a931851c27348b04335aa4c25baf5b2662c85403ad2eb075ce049a724c297a46ea2f796845aebd8 SHA512 386cae12d949a6f4dd55dc7e3e1bc176c43c5001f10acc75261c92fbe14bb09c0e054dfa4087d285496dec4cbd4a9add5733742dbfa82c6e10ee1c8d0f43fb0a
DIST apsw-3.32.2_p1.zip 679785 BLAKE2B fb58a60f95a677a805b0347a0d8876e49c657092deeadb60a057f4afc62031313faf5a86b600d1d306e42f305c9af599d2439a7051e400cbba2d9185c213d5d1 SHA512 718de699c43eec139747f63c3c26da206aa20f104ec1c478009d29cedff7a432138726131b2458ecd3a67675254af77e94e50e8e96a208600fe2a94aa9d924c7
+DIST apsw-3.35.4_p1.zip 685034 BLAKE2B 5845e5fcb286c587367955c33fbee9aa4b0687af666f1d50f35f5dec8e756a0fbcf0fdbd120dd3c7a78df1f05d8eae5a973a8a71fc8a6f4271fff7d83b399013 SHA512 f420560e5821bd6305705ee6c14174f1770f4811edcfe152cb1f2ceae4295f13c82552386a7ef42c5ce88165e88bd2080b4dc2809484598522914d99f2469135
EBUILD apsw-3.32.2_p1.ebuild 986 BLAKE2B c5af577aa9ff6a9fad4d7392d83a6a2b6f6e13149ea02f1bf73f788d87dc5e00458622188a006e211adc1c1f6d6296b29a2ae96e3759a216876c86fb79e8fac4 SHA512 cd23407a45171ae764713803c68fa5cddf693c8044e93bbdbfbe55745f393efa38e88d186452ad37b0a3be8a20b431d818a04f3f8f624a50bc7760e25c6d3910
+EBUILD apsw-3.35.4_p1.ebuild 1053 BLAKE2B 4d44e62fa84781ffec1ea52d92055780e888a402285a5c807c3d1ae363f600bf14e9ecbe96a31b2b2bd115149912ffa3eaf53a3bd206ddfe4e913d326f7c8073 SHA512 6f91f539b59696b89c6e073858ecc75a16e60e5308959c3e2708dac53ed7caf54f2c48cdecfa7e1ce21be9cdab21f1ec7c2b45c9f8d7457af4605c3d1703d986
MISC metadata.xml 699 BLAKE2B bf19c9247293e0352ad99f01a8cab2e64a8ca9af974849eed8b270dab4d5dec4bd803f3b5e29f433df8a0db9a596faed84a6fa4422db2eef5061f6acda63dcf6 SHA512 b8ed61d9356fd05fe274e6634cbd7ffb47ba5a599de8154a9a6016aef184bd63dea018bf453275f3a8a7a9e562fe1eb267276127320a2d3ce7d3c786e3024f49
diff --git a/dev-python/apsw/apsw-3.35.4_p1.ebuild b/dev-python/apsw/apsw-3.35.4_p1.ebuild
new file mode 100644
index 000000000000..9c4c56abd928
--- /dev/null
+++ b/dev-python/apsw/apsw-3.35.4_p1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+MY_PV=${PV/_p/-r}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="https://github.com/rogerbinns/apsw/"
+SRC_URI="https://github.com/rogerbinns/apsw/releases/download/${MY_PV}/${MY_P}.zip -> ${P}.zip"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-db/sqlite-${PV%_p*}"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/unzip"
+
+PATCHES=( "${FILESDIR}/${PN}-3.6.20.1-fix_tests.patch" )
+
+python_prepare_all() {
+ sed -e 's/"gcc/os.environ.get("CC", "gcc") + "/' -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile --enable=load_extension
+}
+
+python_test() {
+ esetup.py build_test_extension
+ "${EPYTHON}" tests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}