summaryrefslogtreecommitdiff
path: root/dev-python/apsw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-01 15:15:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-01 15:15:48 +0100
commit9d396115d657f4e18ffa2c1d073980d8e3d6710f (patch)
tree9f01ba3155b53183847eaf91e63b1e652ed6002f /dev-python/apsw
parenta9b37934d0877c4249ea35c9e9c5b8cf3b836c9e (diff)
gentoo auto-resync : 01:08:2022 - 15:15:48
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/Manifest2
-rw-r--r--dev-python/apsw/apsw-3.39.2.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index e962fb8efce7..c3b5fe974f04 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -1,4 +1,6 @@
AUX apsw-3.6.20.1-fix_tests.patch 340 BLAKE2B c70f404afaed26c92f60690820812fb0ccbe355f43384b4e0a931851c27348b04335aa4c25baf5b2662c85403ad2eb075ce049a724c297a46ea2f796845aebd8 SHA512 386cae12d949a6f4dd55dc7e3e1bc176c43c5001f10acc75261c92fbe14bb09c0e054dfa4087d285496dec4cbd4a9add5733742dbfa82c6e10ee1c8d0f43fb0a
DIST apsw-3.38.5-r1.gh.tar.gz 338186 BLAKE2B 145e38d4057be498f85a655ad7a437ec19a895769f58505b4b99093be30e67498faf9572494009db8e20e6700fa5e514605af131d045a4e8bb41587b828f5a88 SHA512 58331ca2db993f87316a55075ee9c440d4bd6e985e8ca11079391bd9cc2a907271ffe5c21d66840e336cd9e6568f6134c8b8fa5d28bbc7c77a1dddd48e8b99b7
+DIST apsw-3.39.2.0.gh.tar.gz 345634 BLAKE2B 433455fdb0dbc6192bbb3ef47cc1d54faa310715b81312b999a84f90de61e5362e4af8d3a705816100381ae920283d84a50fb2e51308227eecf9de5b7166c4ac SHA512 4d3eb68d47cf8114e7823969277d0f42c4091632d4aeab61f66e91e99601b6a5286875515e860e27a2f736c943dad1657f5c47cbdd23a3d1479d3019bfd1c05b
EBUILD apsw-3.38.5_p1-r1.ebuild 1001 BLAKE2B 34e16dbb37cdac9e86a48591bd96e51b577114b1d306cf4d2935f93ef9efe1bdc55e1086d99d8f91f8a3e736bffeb46d256653d22fa092fff1d6ce3ee9ad8a98 SHA512 d5f9c67b0627695546facd78f000a9dea8ee2fa6e4d3a78ab7604ef21ca4a8c42cc1a07bf694cacde65d72bc6c07f91a702e97c111c26ed81795b660b964f697
+EBUILD apsw-3.39.2.0.ebuild 936 BLAKE2B 17c4326f8f755aebad35df0e38766da34ec0bc06c3e25801f72f7872748fad910fa0908eb083314cba1cb2adaa72502a00bd7fba431929f724d9861410f5f7de SHA512 cba865bbe953de86e0540891c4528610df93a736442128f6f9bd9974b5fc1dc90787128b2eb9d29fabc65faae5e022fdaf6f3077ae58f1b7350dedaf164f8f95
MISC metadata.xml 700 BLAKE2B 258344a1602daf3e081fdb4c94eda8af6e231def3f02fb80d63691b47d0a503c9caad80893386ce7ef42d6be2985906f3fc5cfedfe5a1044aee04c493f3d0683 SHA512 de73b4eb06d0bcf4c81e544a98ad15231b006d62fe22f6bce7e38740b941b98297fa1a38b00060ff83ae9f3259c5020c7071469f2a3f0d9e4f8f0301cb942081
diff --git a/dev-python/apsw/apsw-3.39.2.0.ebuild b/dev-python/apsw/apsw-3.39.2.0.ebuild
new file mode 100644
index 000000000000..68db175bfcfb
--- /dev/null
+++ b/dev-python/apsw/apsw-3.39.2.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="
+ https://github.com/rogerbinns/apsw/
+ https://pypi.org/project/apsw/
+"
+SRC_URI="
+ https://github.com/rogerbinns/apsw/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=dev-db/sqlite-${PV%.*}:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.6.20.1-fix_tests.patch"
+)
+
+python_compile() {
+ # Needed for e.g. bug #851741
+ distutils-r1_python_compile --enable=load_extension
+}
+
+python_test() {
+ esetup.py build_test_extension
+ "${EPYTHON}" tests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}