summaryrefslogtreecommitdiff
path: root/dev-python/apsw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-26 10:30:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-26 10:30:48 +0100
commit96cc0713998c294a9440f03dfa8c4adc9cb71f92 (patch)
treec51c399e2ac466345931e32f9bb465534a74f828 /dev-python/apsw
parent390bde0d9e0b055c7e87ede2f6b3546ec7da02c7 (diff)
gentoo auto-resync : 26:07:2023 - 10:30:48
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/Manifest2
-rw-r--r--dev-python/apsw/apsw-3.42.0.1.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index 737373935802..167e74949c98 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -1,3 +1,5 @@
DIST apsw-3.42.0.0.gh.tar.gz 863081 BLAKE2B 5eee11867e41c396be7cc9bbde1c4bb82a1e294ddd05613d6fbd50ac95c2d5e374632fde3215a838779253ad0f2eb97a4550771767a9f9f7a53c062c7eee5f7e SHA512 e0afa56d1a1d4e8627fe721c36098182efad23128cb053c7c25fc6412d6fe63a50beb66e0bc8dce527c17ff7bd9adb9e71a35fbc4ee769b5231d4dd941b21572
+DIST apsw-3.42.0.1.gh.tar.gz 881270 BLAKE2B a983aebe53f6baf419fb0fec6d87797d11c1e1f0fadd546139c9b9c3cec6f8848e79af46a928597e6cf33937bb2b2e2157cf908cf18152c7f956864e3d09fe2c SHA512 78a02c8e987df90838923b2a2d4838a184e7e8d9be70a09a4a27eb43e9f06546f831895ab519b681f628e5432b3e5b71d56ecc2f3e45a89765dc13667ca6e844
EBUILD apsw-3.42.0.0.ebuild 937 BLAKE2B eb06b97299c588bcd508f66c2b28cf041018e02475c8c1f98ef57162200c73581a5a6c2b597939a1a58cbb6f414d50d39ae6c23f635bcfff59bdb656f8987ee0 SHA512 aa74f1cbbce56f667a266fcdcb1177deb973592b1bf50d19a752497b760e378c9cf14c62da5189f52618584e09612a70b50395ba832d285deb866950313742ab
+EBUILD apsw-3.42.0.1.ebuild 939 BLAKE2B dbb6b99696be58fe131372532914f0733da34538b940cbca6dcfa65bb5be8baaa794bdabdba5642447b8c1792e202e73f0437e614ee5e438857a90731a241ca0 SHA512 1b3a7ce08ef6355d6382d0ad8995d4473d230bec3f450bafa4b61e09c03356476c93fdfa73d658f07974aaf8a3999700ed38cd6d235a4bd5dba0285a6b5f759a
MISC metadata.xml 700 BLAKE2B 258344a1602daf3e081fdb4c94eda8af6e231def3f02fb80d63691b47d0a503c9caad80893386ce7ef42d6be2985906f3fc5cfedfe5a1044aee04c493f3d0683 SHA512 de73b4eb06d0bcf4c81e544a98ad15231b006d62fe22f6bce7e38740b941b98297fa1a38b00060ff83ae9f3259c5020c7071469f2a3f0d9e4f8f0301cb942081
diff --git a/dev-python/apsw/apsw-3.42.0.1.ebuild b/dev-python/apsw/apsw-3.42.0.1.ebuild
new file mode 100644
index 000000000000..cbe98664d4c3
--- /dev/null
+++ b/dev-python/apsw/apsw-3.42.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="
+ https://github.com/rogerbinns/apsw/
+ https://pypi.org/project/apsw/
+"
+SRC_URI="
+ https://github.com/rogerbinns/apsw/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=dev-db/sqlite-${PV%.*}:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ cat >> setup.cfg <<-EOF || die
+ [build_ext]
+ enable=load_extension
+ use_system_sqlite_config=True
+ EOF
+}
+
+python_test() {
+ esetup.py build_test_extension
+ cd "${T}" || die
+ "${EPYTHON}" -m apsw.tests -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}