summaryrefslogtreecommitdiff
path: root/dev-python/apsw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-28 07:18:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-28 07:18:56 +0000
commitc1cdf388025eed22cca32ace0115377d0026e712 (patch)
tree1394fe10d5d45bbeab0b74635f75068fe1345c02 /dev-python/apsw
parent6607d04e823c033d8e5910e4c9104771ca534b12 (diff)
gentoo auto-resync : 28:11:2022 - 07:18:56
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/Manifest2
-rw-r--r--dev-python/apsw/apsw-3.40.0.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index 40e702d9e928..dbab93e9f222 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -1,3 +1,5 @@
DIST apsw-3.39.4.0.gh.tar.gz 371139 BLAKE2B 223736e45b581f96cfcf4cd42f3aa278c0c3cc6b49188ac1979cc30835635f0f935eac8231d7ba0e1ae50f169095e672fe33c7938e6dbf94a7b82fc44d126002 SHA512 c09b367fa5825300c4a4fb82916077208ebd5741f9be4814d33032349eacdd6c7d528430e6d85615c56aaea30995c2575bfbe02876dc8e95e2c337a811df07e7
+DIST apsw-3.40.0.0.gh.tar.gz 402492 BLAKE2B 9539bbffd9cbcdee58e798261f9fb09a3f691d442cc80de664ce3d48b6f36608624e8f0b718edf87171bd8e68999ee16ea3829698e9d3277afa5b33931f464cc SHA512 61ae7d0a6f394176af462c5e80eae1f8fdc9395fcb64d4956c755d552ab0dcac83349633e7867f2fa661a6b707c80b4ae65fd68cd91b0f0d2535aedf65b4a517
EBUILD apsw-3.39.4.0.ebuild 920 BLAKE2B d5aceb7b4d931bfcdb2a463dc1a93a6213c1094f08ef69e6ea370e5774f3a2a0d0500f60d29ef463124a0168252eef58e34ea53a768e68853da20f5d35492e76 SHA512 f26182561323982a3efcf248dc78336c897aebdaeb806a7caba6c22b56351c7a284810235c8b8311edf6358343d53744df8f75ca47868fc0a1cc7654f96cf488
+EBUILD apsw-3.40.0.0.ebuild 922 BLAKE2B 2e5ba86985a6bbfbe66af210c711ede39a125267c49ffcd470a26909942ec61f7521b67d27024426547d9ea01a08a3c22e53c846ffa9edd39f4ff03235581b90 SHA512 bc16789a3d3311f93f018881f0f50ccd0c4d983e5a41224c08305ff3985f4b18ffafe866fcc5916bf4ab3390f202d2bde06b750c4245b2d17bfc5ec3dc684ba2
MISC metadata.xml 700 BLAKE2B 258344a1602daf3e081fdb4c94eda8af6e231def3f02fb80d63691b47d0a503c9caad80893386ce7ef42d6be2985906f3fc5cfedfe5a1044aee04c493f3d0683 SHA512 de73b4eb06d0bcf4c81e544a98ad15231b006d62fe22f6bce7e38740b941b98297fa1a38b00060ff83ae9f3259c5020c7071469f2a3f0d9e4f8f0301cb942081
diff --git a/dev-python/apsw/apsw-3.40.0.0.ebuild b/dev-python/apsw/apsw-3.40.0.0.ebuild
new file mode 100644
index 000000000000..f10a20ff8b30
--- /dev/null
+++ b/dev-python/apsw/apsw-3.40.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="
+ https://github.com/rogerbinns/apsw/
+ https://pypi.org/project/apsw/
+"
+SRC_URI="
+ https://github.com/rogerbinns/apsw/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=dev-db/sqlite-${PV%.*}:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ cat >> setup.cfg <<-EOF || die
+ [build_ext]
+ enable=load_extension
+ use_system_sqlite_config=True
+ EOF
+}
+
+python_test() {
+ esetup.py build_test_extension
+ cd "${T}" || die
+ "${EPYTHON}" -m apsw.tests -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}