summaryrefslogtreecommitdiff
path: root/dev-python/apsw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/apsw
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/Manifest2
-rw-r--r--dev-python/apsw/apsw-3.38.1_p1.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index c09d5a9c7a49..53a8bd600f6d 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -1,4 +1,6 @@
AUX apsw-3.6.20.1-fix_tests.patch 340 BLAKE2B c70f404afaed26c92f60690820812fb0ccbe355f43384b4e0a931851c27348b04335aa4c25baf5b2662c85403ad2eb075ce049a724c297a46ea2f796845aebd8 SHA512 386cae12d949a6f4dd55dc7e3e1bc176c43c5001f10acc75261c92fbe14bb09c0e054dfa4087d285496dec4cbd4a9add5733742dbfa82c6e10ee1c8d0f43fb0a
DIST apsw-3.35.4_p1.zip 685034 BLAKE2B 5845e5fcb286c587367955c33fbee9aa4b0687af666f1d50f35f5dec8e756a0fbcf0fdbd120dd3c7a78df1f05d8eae5a973a8a71fc8a6f4271fff7d83b399013 SHA512 f420560e5821bd6305705ee6c14174f1770f4811edcfe152cb1f2ceae4295f13c82552386a7ef42c5ce88165e88bd2080b4dc2809484598522914d99f2469135
+DIST apsw-3.38.1-r1.gh.tar.gz 338985 BLAKE2B aa0ef335bd3abc708b41a92959f98b4fd3961168feacb9ca6d382e0279c46d4227a8e09373721ae1361fcc38181376664130b3623b2f36e1596467b99959ecb8 SHA512 4d161641d7bf7f933507e7d7e71d437d9db95f7327e29cf34848d9b741e2711dafbefbf19cb34d78d83b4e69115acad855f924fdf80de1cea4c9d61fe0f2b670
EBUILD apsw-3.35.4_p1.ebuild 1051 BLAKE2B 668a4051c5238535b4f267c6c1a6fed22db382ca1d8884f16216b0e98ffb6dc5fe34dca93082519e9941372acff79f2b05f024f4bd3c95cf6c7d06a8cdf3096e SHA512 ac359e50a625bc456e617808841a531b4760a8c19121dbd16b604cffd6bfcca0212a45cbb247db804a1712da1c74b1c20488043880f0c9417cc45bb13ea4c398
+EBUILD apsw-3.38.1_p1.ebuild 1077 BLAKE2B 76097082cb7e0e24ffc9054403f990c34c898677c7e6fe84e303f07072b5ce1a5c89b0e724d39613f446c667c1e8c81b8adb7276026b640e5e0e02a5bba61a3b SHA512 dd792554075a92af0447c46384d4b3fdaec847b712f35716abaf9c31c42009f5cd98729d8bbc89b1bf595dfb0edfc19bb2392f60a75ef7a5eef4e75b7ad66455
MISC metadata.xml 700 BLAKE2B 258344a1602daf3e081fdb4c94eda8af6e231def3f02fb80d63691b47d0a503c9caad80893386ce7ef42d6be2985906f3fc5cfedfe5a1044aee04c493f3d0683 SHA512 de73b4eb06d0bcf4c81e544a98ad15231b006d62fe22f6bce7e38740b941b98297fa1a38b00060ff83ae9f3259c5020c7071469f2a3f0d9e4f8f0301cb942081
diff --git a/dev-python/apsw/apsw-3.38.1_p1.ebuild b/dev-python/apsw/apsw-3.38.1_p1.ebuild
new file mode 100644
index 000000000000..64f34312b92b
--- /dev/null
+++ b/dev-python/apsw/apsw-3.38.1_p1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PV=${PV/_p/-r}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="
+ https://github.com/rogerbinns/apsw/
+ https://pypi.org/project/apsw/
+"
+SRC_URI="
+ https://github.com/rogerbinns/apsw/archive/${MY_PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=dev-db/sqlite-${PV%_p*}:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.6.20.1-fix_tests.patch"
+)
+
+python_compile() {
+ distutils-r1_python_compile --enable=load_extension
+ mv "${BUILD_DIR}/install${EPREFIX}/usr/apsw.pyi" \
+ "${BUILD_DIR}/install$(python_get_sitedir)" || die
+}
+
+python_test() {
+ esetup.py build_test_extension
+ "${EPYTHON}" tests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}