summaryrefslogtreecommitdiff
path: root/dev-python/apsw/apsw-3.39.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-22 17:28:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-22 17:28:08 +0100
commitd79ab35b7ac170babebe8bc151fe5d037c16285c (patch)
treec774a4913f32e952079ae36fc6afd2dad747837f /dev-python/apsw/apsw-3.39.2.1-r1.ebuild
parent992aa50a54a56c9e705ca4e85d809ec8989d74a2 (diff)
gentoo auto-resync : 22:09:2022 - 17:28:08
Diffstat (limited to 'dev-python/apsw/apsw-3.39.2.1-r1.ebuild')
-rw-r--r--dev-python/apsw/apsw-3.39.2.1-r1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/apsw/apsw-3.39.2.1-r1.ebuild b/dev-python/apsw/apsw-3.39.2.1-r1.ebuild
index a8edc30d8529..2e0e6c51a7da 100644
--- a/dev-python/apsw/apsw-3.39.2.1-r1.ebuild
+++ b/dev-python/apsw/apsw-3.39.2.1-r1.ebuild
@@ -30,10 +30,11 @@ RDEPEND="
${DEPEND}
"
-python_compile() {
- # Needed for e.g. bug #851741
- # Enable column-metadata to match dev-db/sqlite
- distutils-r1_python_compile --enable=load_extension,column_metadata
+src_configure() {
+ cat >> setup.cfg <<-EOF || die
+ [build_ext]
+ enable=load_extension,column_metadata
+ EOF
}
python_test() {