summaryrefslogtreecommitdiff
path: root/dev-python/apprise
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-13 00:01:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-13 00:01:18 +0100
commita25cc082a26782e5d39ded4559c91ff11bc3c299 (patch)
tree6cd0802dd248058d540f1f5f472c5df98216f154 /dev-python/apprise
parentd72a987a342949e200b5e9decbd71f246da53788 (diff)
gentoo auto-resync : 13:05:2024 - 00:01:18
Diffstat (limited to 'dev-python/apprise')
-rw-r--r--dev-python/apprise/Manifest2
-rw-r--r--dev-python/apprise/apprise-1.8.0.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/apprise/Manifest b/dev-python/apprise/Manifest
index 3c128c85574b..fc1b4f47aea7 100644
--- a/dev-python/apprise/Manifest
+++ b/dev-python/apprise/Manifest
@@ -1,3 +1,5 @@
DIST apprise-1.7.6.tar.gz 1656123 BLAKE2B 49720f6ba6522f3496ad5cbf5bf72340c6b21f207d11f3c3fcdd113db2e01730b64209fad1d0c7f1ed357251e567a0fe8c875b2ab8f1befdeeab9af59f5678e3 SHA512 39fdfd129d9e8bc16070a015bc9e2b4f4bf6e61e1b87ee45ec11e99e7e87dcc3896312c7ff71d0dac9532cee36709de40d6397d98b8affda069cb3a436ab8683
+DIST apprise-1.8.0.tar.gz 1651688 BLAKE2B 32458b2a4787c0366db54890b505ca86cf1abee4299d32fd49f8fc8d37b87a6123c902747f97466b061857e7f284ed78c4001e61f587f3b47e17194324217d37 SHA512 312165b1b5c05ee632b5f2631eafc4af2b318881444851966ff6893775caa303b8d8fc819de9c2f8790eb224ac849535c5e5038a2f51dc30d477a503ed48b920
EBUILD apprise-1.7.6.ebuild 894 BLAKE2B e856be36348ff265cb46650bc374d9a227b251d28384f5b0215daff87754c38365e56a683a75b5791ece4a724a6780da1df91b40a93bb61a18cfa5e6ea46822f SHA512 7e5193bd302bdc105a620c07a0dba4ee1df20af98e745472d43979f4fd6ec1a8c29172e050327165bcf788d3315f3f9546fbe7d1497d0cc226cfd7aec98dbc0f
+EBUILD apprise-1.8.0.ebuild 895 BLAKE2B c00ba1868a8bf8f8cedffbf3ff816b35ca67476e955b7083571a06b690012e8a999d74b5518d83885fa5d2b2937100a2370cff66530e760cfb9818aed463ef49 SHA512 8604514dcf11353158f08e2ad60191b0cc5eb52e7124c9f8e2a967fc4c284ca5f7b73b56b4d6a6d4bdeb02ac197b10116bd0ecdf24ea2152800476399a3ddfe8
MISC metadata.xml 660 BLAKE2B e5d3535632acf00f228e96b2deca73aca518faf9f9e3ec032e13fdea4480e3f83791b3846e456ae47a917a3462c47882358c3ea1c69d20b6332a6ade65340211 SHA512 4c69871bdd771b7cc1af57e018ed1cc1f2194bdf2f7c1e750433911cf75e45f8fa4aa82df71255ce0a1c949db9d220ed614d5932ccf1ff5e78976bec482751a6
diff --git a/dev-python/apprise/apprise-1.8.0.ebuild b/dev-python/apprise/apprise-1.8.0.ebuild
new file mode 100644
index 000000000000..a85837c32c40
--- /dev/null
+++ b/dev-python/apprise/apprise-1.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Push Notifications that work with just about every platform"
+HOMEPAGE="
+ https://pypi.org/project/apprise/
+ https://github.com/caronc/apprise/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+IUSE="+dbus mqtt"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ mqtt? ( dev-python/paho-mqtt[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest