summaryrefslogtreecommitdiff
path: root/dev-python/apispec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-22 13:48:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-22 13:48:31 +0000
commit9173f73d44f3cbc858477bd71e7680ede7d98e0d (patch)
treeae2808502a372289467a6ce425f580c1473ee15e /dev-python/apispec
parent591f45259704c7c0c4289228107c6ee61457420e (diff)
gentoo auto-resync : 22:12:2023 - 13:48:30
Diffstat (limited to 'dev-python/apispec')
-rw-r--r--dev-python/apispec/Manifest2
-rw-r--r--dev-python/apispec/apispec-6.3.1.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index a55cf538a4cf..a32209be8da5 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1,3 +1,5 @@
DIST apispec-6.3.0.tar.gz 77157 BLAKE2B 0ccf398f36548ea269c4e91fb512d8789bb387cff6956c0fe0426f1b3c38b6670e8c41972948d7a3f87c75e52c97fdff7570306d64c6ad41bfcb9f19e391b7de SHA512 65119851ee31cebc0bb0ddc6668e3961f870a7759bc95128e67063d0f3c6a88ddb590efc478c2e8eb8ecd7d3edd51bd51971a4e3e1e25a7486dfcb1b49e98dc4
+DIST apispec-6.3.1.tar.gz 77634 BLAKE2B e98a4d14f12248b27af1b5b12b642e416af7cf4f36386406ad0784e7d8930a71391de2ed627d6093e907048bb3a145abf06fca1b5b3e0595346d45fd6be6775f SHA512 977d9f890728a336b8e604f5ab7feb850f0f65e9fb64aa10cb2697d27bbd89137c6b08719b6cc422efc11c80cea6f6646709c33d340b0a63345fe93f2aa92902
EBUILD apispec-6.3.0.ebuild 1022 BLAKE2B 89762d087bb0e554ae2f7af16e5aaeb9eba4bf39ab1f36fde93c5b4dcf1e5abbe09cbbbe242b6aac2d4b4051396d04041800e4f5f3fa2a17df4cd779a11ee75e SHA512 88b5b95dc4a46dca85492cbb29e4d6cf1a7f6e69ed00f3ce43c6e25f38f19131b221b7f6885b4b1864f89eb265a68ad5ea5cfcad24136a8463b39cbe826dd2c0
+EBUILD apispec-6.3.1.ebuild 1023 BLAKE2B 9b47968855adc0f7e8ad46580a8cea7f6804a31cd038b6e62a911c17fd927b79cf677d615789768cff502ccb083445c174f1d1958c8a1d645dd98961d349b381 SHA512 d900933e86c767bc667d7f97e2382548374715f2fddd43648969447acdb41b5b4680d0995fe977b49f9881139e4bd017d15c6f07c820ff9073be2652b40e8958
MISC metadata.xml 504 BLAKE2B d55ae521520ba60a139e83f23aacbb3df76c4c120a54f1b65b185018647c1f363bc88f354abc1810b7a9d9f3cfa264e0303d46cd23b8091dbb365bd84cc04815 SHA512 e0297e941c3c544cbb14044f02451c26cfdec81b2bd49cf225dc9f32d1ccb207e630d838d8928d28ccb35a3cf01493a87ceb2633cc5ede36b62a6d81f164ea32
diff --git a/dev-python/apispec/apispec-6.3.1.ebuild b/dev-python/apispec/apispec-6.3.1.ebuild
new file mode 100644
index 000000000000..a64dc15f67a5
--- /dev/null
+++ b/dev-python/apispec/apispec-6.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pluggable API specification generator"
+HOMEPAGE="
+ https://github.com/marshmallow-code/apispec/
+ https://pypi.org/project/apispec/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.18.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}