summaryrefslogtreecommitdiff
path: root/dev-python/apispec/apispec-6.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-27 11:40:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-27 11:40:34 +0000
commite4be1c42deab59fa5baee33fa9b1c48e5c4c6dc7 (patch)
treeb4534a27fdf6bf08f5703b897a4684732e78151a /dev-python/apispec/apispec-6.5.0.ebuild
parent0a5376618896a890256bc26687f4cd8bbe302df6 (diff)
gentoo auto-resync : 27:02:2024 - 11:40:34
Diffstat (limited to 'dev-python/apispec/apispec-6.5.0.ebuild')
-rw-r--r--dev-python/apispec/apispec-6.5.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/apispec/apispec-6.5.0.ebuild b/dev-python/apispec/apispec-6.5.0.ebuild
new file mode 100644
index 000000000000..7d9e2538b1f3
--- /dev/null
+++ b/dev-python/apispec/apispec-6.5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pluggable API specification generator"
+HOMEPAGE="
+ https://github.com/marshmallow-code/apispec/
+ https://pypi.org/project/apispec/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.18.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}