summaryrefslogtreecommitdiff
path: root/dev-python/anyio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
commit34dea8e38f88007799629d0a56b12dec480b1d21 (patch)
tree6790873994b58030360328cf5897d934b3b03d16 /dev-python/anyio
parent7932d472a02d4c016ff7dff4b7a5479ab9d1883d (diff)
gentoo resync : 20.06.2021
Diffstat (limited to 'dev-python/anyio')
-rw-r--r--dev-python/anyio/Manifest2
-rw-r--r--dev-python/anyio/anyio-3.2.0.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/anyio/Manifest b/dev-python/anyio/Manifest
index a80ffc318926..37ba2f1417ed 100644
--- a/dev-python/anyio/Manifest
+++ b/dev-python/anyio/Manifest
@@ -1,3 +1,5 @@
DIST anyio-3.1.0.tar.gz 122097 BLAKE2B 4a16a5d231cc5262dd4138f628b9d210180733bda4b9e81ced0c0e0c7f49e1760c8dd22db0a1db3b7a21f3210072f4e1c543e52a7dc716ad3f0415827da48e38 SHA512 120d8e3e24f542c06caedd0a67d16b3fb69c94f5feaebde5262e54f8ffba3f1cf927c82030d65fa2efb3479ee64abd968b6ce67aee767ea33ccef6b0e3fbd358
+DIST anyio-3.2.0.tar.gz 126210 BLAKE2B cedace636a115ad579ca47b345bb2a9bb32e97fa2ef886a9e6bd19219dcc92c393aaaf480df5e6f48c959590c2d6a3e0770f700ab4901c7a8e576b231597abf1 SHA512 f4e718704225d9cbb8e2592246ac393f96e82fb1898bc0ff89b2d7990c4aac7e7c9b339cb57a594c59a9e5730696122c9e647310c26e00ab152879e0a7e85863
EBUILD anyio-3.1.0.ebuild 1413 BLAKE2B 35471e090dad1e7d2a820c2c1d225e211311f673bf8d4a6d1adf5d0221d293fad3813295b17ddac496f603a1e26737b7bd43135361f4c5cfbfd29b48fd479f21 SHA512 dff8ec2ff5c87f0bea1d083fe62685c4580580e17bcedb14b014396a280e2468cd548b44bb492e5b64b09c61c49a4f86f043dcbd7e4a1bddb58b8bfff5b443de
+EBUILD anyio-3.2.0.ebuild 1418 BLAKE2B 398427069cbee61cf7ae0111c76933c8908760619f4fd6c26622bafbe68e58287af7d916418aea7b06c8c96b928aefc5242bbebfece4ce9e03676b11b1d0510c SHA512 eb3abcab9ad4e5e26dc861508f881e3f96895eb120951be2be685c0727b0efa9a240a57caaf530076bcce8b229514fd1c80fc0f41bdf13a433aaf8ffc97c795d
MISC metadata.xml 1320 BLAKE2B 0687bd9663338d0f39ad5b705f3ba3064ad7a399e31e6b6dfba80124b4ce719bbde82fb39f8b19b4a2fd22a040919163a59bfb57a3db143983d60db78d05811e SHA512 306491b404e5929eb19f61e359741b2961b3e600e3e6190e29215ea571db2d270d469c331956246f3336e05f5379d37d35bbea30931a9bbd8fb79a671d7642ce
diff --git a/dev-python/anyio/anyio-3.2.0.ebuild b/dev-python/anyio/anyio-3.2.0.ebuild
new file mode 100644
index 000000000000..370889746426
--- /dev/null
+++ b/dev-python/anyio/anyio-3.2.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Compatibility layer for multiple asynchronous event loop implementations"
+HOMEPAGE="
+ https://github.com/agronholm/anyio
+ https://pypi.org/project/anyio/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+
+RDEPEND="
+ >=dev-python/idna-2.8[${PYTHON_USEDEP}]
+ >=dev-python/sniffio-1.1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ >=dev-python/uvloop-0.15[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinx-autodoc-typehints
+
+python_prepare_all() {
+ # This will pull in dev-python/trio and a whole bunch of other new things
+ # And trio does not yet have a release compatible with python3.9.
+ rm tests/test_taskgroups.py || die
+ sed -i -e '/trio/d' tests/conftest.py || die
+ sed -i -e 's/test_cancel_scope_in_asyncgen_fixture/_&/' \
+ -e 's/test_autouse_async_fixture/_&/' \
+ -e 's/test_plugin/_&/' \
+ tests/test_pytest_plugin.py || die
+
+ # skip network test
+ sed -i -e 's/test_getaddrinfo/_&/' tests/test_sockets.py || die
+
+ distutils-r1_python_prepare_all
+}