summaryrefslogtreecommitdiff
path: root/dev-python/ansible-pygments/ansible-pygments-0.1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-27 16:01:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-27 16:01:10 +0000
commit724cccb689f2076a398ede6845749926c86ea647 (patch)
tree766c785a64ac7265adee059e793fc120be6c434f /dev-python/ansible-pygments/ansible-pygments-0.1.1-r1.ebuild
parent73ef00f9e2b100c7d0fedede11300940cc26670a (diff)
gentoo auto-resync : 27:02:2023 - 16:01:10
Diffstat (limited to 'dev-python/ansible-pygments/ansible-pygments-0.1.1-r1.ebuild')
-rw-r--r--dev-python/ansible-pygments/ansible-pygments-0.1.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/ansible-pygments/ansible-pygments-0.1.1-r1.ebuild b/dev-python/ansible-pygments/ansible-pygments-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..245c0808deda
--- /dev/null
+++ b/dev-python/ansible-pygments/ansible-pygments-0.1.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517="poetry"
+
+inherit distutils-r1
+
+DESCRIPTION="Pygments lexer and style Ansible snippets"
+HOMEPAGE="https://github.com/ansible-community/ansible-pygments"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~riscv"
+
+# 2.14.0+ needed in order for tests to pass
+RDEPEND=">=dev-python/pygments-2.14.0[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.1.1-tests_pygments2_14.patch
+)
+
+distutils_enable_tests pytest