summaryrefslogtreecommitdiff
path: root/dev-python/ansible-compat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-14 13:40:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-14 13:40:00 +0100
commit3e627c1432765cb6a32877e73f985e8bfb5102ce (patch)
treee4d7919d9e1ca0a54c1a3758c86555d6e9121956 /dev-python/ansible-compat
parent4a30f472147c2d8642bd558b78fcfce7b6a9c6b9 (diff)
gentoo auto-resync : 14:07:2022 - 13:40:00
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/Manifest2
-rw-r--r--dev-python/ansible-compat/ansible-compat-2.2.0.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index e4d5c3f3daa0..99815f089c54 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1,3 +1,5 @@
DIST ansible-compat-2.1.0.tar.gz 37840 BLAKE2B 5ac74cdaef1c932094996f331ed94418836b3351cbd376ae35ef22046b68dad0a8ab68fd293015db9954e0a5e1df4b5c529b3845cee5778daed2bb207733ca4f SHA512 a85681aff3d34ef4a4cdad8f419017a174bf315034495bc032a7e33d586cbcf72de74d163b6faf3cd21988704e5dbb922872b83a23981891311dbb18e53797a3
+DIST ansible-compat-2.2.0.tar.gz 38772 BLAKE2B dbe74d23d2f2e4275bd9df2303417ea83517e780e65c6a34bd6ae1022be265ac816b50b309fc45f88e0c7fac7d7a22c83a826cc15be050698a6f35b267a36ac3 SHA512 3bd199431659ecba52743c6c985d2cdc6ee55396444241ba2456bc5430bbc87e26087dffbfff62ac341fa854e19baa0d7052cf79f20511222fd9e001dd020136
EBUILD ansible-compat-2.1.0.ebuild 1801 BLAKE2B 429e761c9a8dc220ef53274cba9f0da1a1647ee483e6afb0bf98fe14e25507d907b4515d4fc266ddbd53cc96cb105c172fc800c98c2a1becbc85c43900f64be6 SHA512 8c299014a4005e2a6e199e848e8829b792368c1862311c07b77d8df258ef6b16ec2bca27c2cf3a78f879052aa883267f37f91b2ac725a53787bb84923d1d7e62
+EBUILD ansible-compat-2.2.0.ebuild 1841 BLAKE2B 18b983fbaa4703f3cb6722af2ca267892a1976af3a12bdb8032a1844a0d9f24e2f1e746a610590cc865d0b4e0df64d2cb31d32ff952c0b6dce3067a08d945c6c SHA512 42df422e2736d933b1f54a3af171c9e40ad45a5df57e91b8da1b5255a6de7777e840a3cdb6f983cb16f255ac324935d5d69f86ee8f351ce1f048a3b59486b6bf
MISC metadata.xml 510 BLAKE2B 3f47270866cb9acc5944b71547640b69003891268ffc07b5cd10e6ba8842b6f644ab4dea3b3da2d20b17f34d90e565b6f03a4dbb8ea38fa282fed283ac22fac1 SHA512 65d8604e46581bf9ecb3d8e358f3a211b18c51beea22c92a1cd3668ba86140e3bd8d91a38c221e73fe13a3e0da1cbfc2030b3f7733ee55e045530b49cd77d46d
diff --git a/dev-python/ansible-compat/ansible-compat-2.2.0.ebuild b/dev-python/ansible-compat/ansible-compat-2.2.0.ebuild
new file mode 100644
index 000000000000..36ec1e075135
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-2.2.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-base-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.3.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-6.3.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-markdown[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+)
+
+distutils_enable_sphinx docs \
+ dev-python/ansible-pygments \
+ dev-python/myst_parser \
+ dev-python/sphinx_ansible_theme
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p pytest_markdown.plugin
+}