summaryrefslogtreecommitdiff
path: root/dev-python/ansible-compat/ansible-compat-4.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-02 15:29:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-02 15:29:04 +0100
commit27c1d146e5ee9e472a31a7958ad4dc70a5451ea7 (patch)
treefe573cd3516126d757c143a469871b88e5851548 /dev-python/ansible-compat/ansible-compat-4.1.2.ebuild
parentbc3875d3a71ac3fdb07c0fcf863843b4fdfcf0c0 (diff)
gentoo auto-resync : 02:06:2023 - 15:29:04
Diffstat (limited to 'dev-python/ansible-compat/ansible-compat-4.1.2.ebuild')
-rw-r--r--dev-python/ansible-compat/ansible-compat-4.1.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/ansible-compat-4.1.2.ebuild b/dev-python/ansible-compat/ansible-compat-4.1.2.ebuild
new file mode 100644
index 000000000000..bbea175e5664
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-4.1.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+)
+
+distutils_enable_tests pytest