summaryrefslogtreecommitdiff
path: root/dev-python/ament_package/ament_package-0.12.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /dev-python/ament_package/ament_package-0.12.0.ebuild
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'dev-python/ament_package/ament_package-0.12.0.ebuild')
-rw-r--r--dev-python/ament_package/ament_package-0.12.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/ament_package/ament_package-0.12.0.ebuild b/dev-python/ament_package/ament_package-0.12.0.ebuild
new file mode 100644
index 000000000000..6027deba39c6
--- /dev/null
+++ b/dev-python/ament_package/ament_package-0.12.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_7,3_8,3_9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Parser for the manifest files in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_package"
+SRC_URI="https://github.com/ament/ament_package/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test || die
+}